I'm connecting to internet through router which updates the IP to DynDNS. Within my home network, I can access the WebUI with


If my DynDNS domain is http://mydomain.ath.cx, how can I access the WebUI of my system? Currently I can access my router page from outside with http://mydomain.ath.cx

But how to connect to my WebUI?

8 Answers 8


If the WebUI runs on the router, then http://mydomain.ath.cx:8080/gui/ should work, unless the router blocks access to that port from outside - in that case you'd have to configure it to allow outside access. If the WebUI does not run on the router, you have to configure the router to do port forwarding of 8080 to localip.

  • I did the port forwarding to my local system IP (static). Had missed that earlier. Still it is not working. Didn't find a place in the router page to unblock or see whether the port is blocked. Aug 4, 2009 at 19:43
  • btw had to change the port to 8086 everywhere as router page showed some conflicts when I forwarded 8080. Hope that is not a problem. Aug 4, 2009 at 19:45
  • If you activate port forwarding, then the router should not block the port if it's programmed sensibly. Using a different port should cause no probelms at all as long as you're consistent about it. So does it work now? Aug 4, 2009 at 20:20
  • If its still not working, you might wan't to try briefly setting the machine as a DMZ for testing. If it works when your machine is DMZ then you know its a router problem (port blocked or not forwarded correctly).
    – Kells
    Aug 7, 2009 at 14:49

You might want to check out the Port Forward site.


Get the internal IP of your machine and forward any external port you want to the internal port (although it is best to use the same) and the correct ip address.

Then, from anywhere in the world, type http://YOUR_IP:80 or whatever port and you should be able to access it.


I actually had to figure this out the hard way earlier today. Make sure that the Firewall allows incoming connections on the port, and that the router forwards the ports correctly. If you have that, it should be able to work with http://mydomain.ath.cx:8080/gui... if that doesnt work, you may need to set up a slightly different address with your domain provider to go to ipaddr:8080/gui, or just type it in manually each time (which is what i have a bookmark for)


As has been mentioned above, you need to configure your router to forward a port on the Internet side e.g. 8080 to port 8080 on machine "localip". When you access, yourdyndnsdomain:8080 it will be handled by localip:8080. You could forward port 80 to localip:8080 and then yourdyndnsdomain will automatically be handled by localip:8080. I'm assuming that this is obvious.

You say that, you get your router page when you access yourdyndnsdomain from the Internet. This is not advisable and you want to turn that off as you run the risk of attack against it if it is picked up by some bot or script kiddy out there. Google could be used to search for this router and at best someone will try the default admin name and password, followed by every known common password. At worst, as soon as a vulnerability is found with the router's web interface, an intruder will take it over. This could be done almost invisibly.

Turn off your router's admin interface on the Internet side unless absolutely necessary and only if you are sure about how to keep it safe.

Likewise, put your WebUI on a high unusual port as it also is potentially vulnerable. An attacker will try port 80 and then probably 8080 to see if there is anything there and then move on if it is not interesting. If it is vulnerable, your machine could be compromised in seconds. It's unlikely that anyone will completely scan the ports on your domain but again it is better not to leave the WebUI running if not necessary.


In addition to port forwarding, you might also want to make sure you check your computer's firewall to see if it allows port 8080/8086 (whichever one you're actually using now).

Sounds trivial, but I've forgotten this relatively braindead-easy step several times when configuring my ports, and you seem to have gotten the port forwarding part down correctly.


I ran into the same issue on qBitorrent v4.1.5 using my wan IP. My router did list a correct UPnP entry in the port forwarding screen and canyouseeme.org listed the address as visible, but somehow the actual forwarding didn't work.

For me the solution was to uncheck "Use UPnP / NAT-PMP to forward the port from my router" like the screenshot below, and add the port forwarding manually in the config of my router.

Disable UPnP for web ui


What you are trying to do here is run RDP from outside your local subnet. This is relatively easy to do as long as you consider a few things. First you need to get the traffic to your doorstep. You seem to have done already with DynDNS so there is no need to re-invent the wheel here. Next you need to configure your router to forward the RDP port to your local machine running your UI. Here is a good article if you do not already know how to do this. RDP uses port 3389.

Make sure RDP is enabled on your machine and ensure that the windows firewall is not blocking that program.

At this point you should be able to go to your DynDNS hostname using "mstsc.exe" to access RDP on port 3389!


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.