0

When I ssh to a remote Linux host and type "tmux -u -CC new -A -s main", an alert pops up on as says "Invalid options: @uservars". Below that:

flags = 0; id = 1698437271; 
inList = 1; isInitial = 1; 
lastInList = 1; 
object = 5; 
sel = "getUserVarsResponse:pane:"; 
string = "show-options -v -p -t %5 @uservars"; 
target = "<TmuxWindowOpener: 0x60000320eb10>"; 
timestamp = "21021.099287"; 
} 

This began happening today after I set up my new Macbook and used it to ssh to the remote host. A profile in my iterm2 sends this command to the host every time I start a session on that host, but I can also replicate it by just typing that command into the bash shell prompt on the remote host. This doesn't happen why I connect to the same server from my old Macbook (I haven't sent it back yet).

I have tmux 3.3a installed on the host. I have no tmux.conf file in my home directory. I ran "grep @uservars" in my home dir and in .config and .local, but it found nothing. How can I continue to troubleshoot this?

I read https://stackoverflow.com/questions/66040334/invalid-options-in-tmux-without-custom-configuration but it was not helpful.

0

You must log in to answer this question.

Browse other questions tagged .