Possible Duplicate:
Disable or delay alt-tab Aero Peek effect in Windows 7

In win7, when we hit alt-tab a nice preview comes up.

This makes me happy.

But if I linger just a moment too long thinking about what window to switch to, whatever window happens to be highlighted gets displayed, hiding the preview. Move the mouse around and windows flip all over the place haphazardly.

This makes me sad.

Is there a way to stop the preview of windows from happening so I can alt-tab without worrying about the list of windows being hidden from me by the evil usability "experts" at microsoft (I've decided Catbert secretly heads that department too).

  • 5
    You can also Windows Key + Tab for an admittedly over-the-top graphic preview experience.
    – JYelton
    Aug 27, 2010 at 20:20
  • 2
    "This makes me happy...This makes me sad" - LOL :-)
    – abstrask
    Nov 18, 2013 at 7:44

3 Answers 3


In Advanced System Settings (accessible from the System control panel), click the Advanced tab, then the settings button for Performance.

In the list of Visual Effects, two options affect this behavior:

  • Enable Aero Peek
  • Enable desktop composition

The first is responsible for the translucent "peek" behavior and the second for the ability for alt+tab to show what DWC (desktop window composition) is getting as the image to show for the program in question. Without desktop composition, you won't get the preview icons.

  • 22
    Having had the same problem as the asker, I found that turning off Aero Peek and leaving on Desktop Composition resulted in the desired behavior. Turning off Desktop Composition replaced the new Windows 7 alt-tab functionality altogether with something similar to the older alt-tab experience. Sep 8, 2010 at 14:28
  • 3
    Awesome setting! Turning off Aero Peek disables the background preview, and makes the user experience much better. Sep 14, 2010 at 16:57
  • Very useful information. I turned off "Aero Peek" and now the Alt+Tab functionality is actually functional. Thank you. Oct 23, 2012 at 10:06
  • 1
    Thank god. This works in Win2012, too. Didn't see an "enable desktop composition", but disabling Aero Peek is enough.
    – neminem
    Aug 27, 2013 at 20:59
  • 1
    I wasn't able to get to Performance without authenticating with my admin account, which is a different user. I was able to disable Aero Peek using mivk's answer below.
    – a_hardin
    Apr 10, 2014 at 1:42
value AltTabSettings:
0 - preview
1 - "old-style" (icons only)

press Ctrl - Alt - Del, then Esc (go to logon window and return back to the desktop) to apply this setting


If you want to automate the settings for Aero Peek and Desktop Composition, you can tweak these registry settings:


For example, to disable Aero Peek:

REG ADD HKCU\Software\Microsoft\Windows\DWM /v EnableAeroPeek /t REG_DWORD /d 0 /f

If you tweak CompositionPolicy, you may need to run (as admin):

net stop uxsms
net start uxsms

For some weird reason, it seems Desktop Composition is enabled when CompositionPolicy is "0", and disabled when it is "1".

A few other relevant registry entries to check are


However, the interaction between the "Perfomance Options" / "Visual Effects" window and the registry is quite mysterious and I never found a decent reference about it.

  • Thanks, this helped since I wasn't able to get to Performance as my lower privileged as mentioned in JYelton's answer.
    – a_hardin
    Apr 10, 2014 at 1:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.