These days I was suspecting something weird after the installation of my OS updates. I use the dark theme on my Pop_OS and automatically my web navigators Chrome and Firefox are synchronized with the same theme from my OS.

I am trying to let only my OS on dark mode, and the navigators with dark only on their themes but not on their settings, inspect, see source code for example. Any possibility of making this change only at OS and navigator theme?

I have tried in Settings > Appearance to modify the theme to each one of the options: GTK, QT, and Classic but nothing happened, I always have to change the desktop appearance to light or change each opened page which is dark to light to make possible.

  • Have you tried these steps? winhelponline.com/blog/… They appear to be Windows-specific, but the flags suggested might also work in Linux. Nov 15 at 0:13
  • I have tried lots of things, since this command: gsettings set org.gnome.desktop.interface color-scheme prefer-light on command line terminal, also disabled in chrome://flags/#enable-force-dark, and in /usr/share/applications/google-chrome.desktop file to change this line: Exec=/usr/bin/google-chrome-stable by this one: Exec=/usr/bin/google-chrome-stable --disable-features=DarkMode but I didn't get any results Nov 15 at 4:44
  • 1
    Does this answer your question? How to force websites opened in Google Chrome to light mode on Linux
    – Destroy666
    11 hours ago
  • That's assuming you're talking mainly about websites as the question isn't fully clear and people confuse browser theme and website preferences all the time for some reason. As can be seen in that question with 2 replies that aren't even answering it.
    – Destroy666
    11 hours ago


You must log in to answer this question.

Browse other questions tagged .