1

I want to be able to connect to my Raspberry Pi either via ssh or through connection like server-client from WAN which I think I need to do with port forwarding which is what I'm having problems with.

I just adjusted my router's port forwarding to be as shown below ( external ip address i.e public ip was changed so I don't dox myself).

enter image description here

I have made static ip address on my Raspberry Pi and changed listening (ssh) port to 2525 and I'm still unable to achieve connection when doing something like: ssh user@public_ip -p 2525

This is my firewall protection

enter image description here

My router is "Ubee WI-FI Modem" and I haven't found any documentation about it

What else could cause a problem when port forwarding besides what's on the router's page about pw?

12
  • 1
    Please clarify your specific problem or provide additional details to highlight exactly what you need. As it's currently written, it's hard to tell exactly what you're asking.
    – Community Bot
    Commented Dec 6, 2023 at 19:48
  • Am I guessing right that your actual 'external' IP address starts with 100.16.? Commented Dec 6, 2023 at 21:10
  • restart the router maybe &or rpi
    – Petepf
    Commented Dec 6, 2023 at 23:44
  • @u1686_grawity yes, in my understanding that's public ip, the one used to access my pi. Commented Dec 7, 2023 at 8:35
  • 1
    @Petepf been there done that, doesn't fix the issue Commented Dec 7, 2023 at 8:35

1 Answer 1

-1
  • While you could use 2525 as external port for SSH on your modem, internally I would use 22. If you keep 2525 internally, can you connect to the laptop on 2525 from another laptop?
  • SSH uses TCP
  • Your RPi might have an active firewall. Disable that to make sure it isn't the problem here.

Not the answer you're looking for? Browse other questions tagged .