I have a Word document.

It has two parts: one English and one Arabic.

The problem is that all the numbers are English numbers [0123456789], but I want the Arabic part's numbers to be Arabic numbers [٠١٢٣٤٥٦٧٨٩].

How can I do that in Word 2007 or 2010?

Since I didn't receive any response I created a program that converts English numbers to Arabic and then I use it to convert the numbers in the document. I am still wondering if there is a easier way to do it?

  • 7
    Tech Writer nitpick: The digits used in the West are usually known as "Arabic Numerals". That's because they were introduced into Europe by Arab scholars. They derive from symbols used in northwestern Africa and are sometimes called "western Arabic". The digits used in Arabic-speaking countries originate in the Middle East and are called "eastern Arabic" by us. Arabs call them "Hindu numerals" because they originated in India. – Isaac Rabinovitch Jun 4 '13 at 19:55
up vote 16 down vote accepted

In Word 2010:

Go to File > Options > Advanced.

Scroll down to the Show document content section - you will find the Numeral option. Set it to Context.

Screenshot

  • 3
    this is work perfectly in word 2013 but what about word 2016 ??? – AminM Feb 2 '16 at 8:56
  • That works for certain numbering, but not for things like end of book indexes. – Erfan Jun 15 '17 at 6:22
  • @AminM it is working fine in 2016 in a similar way. If you are not getting, try changing the font. Make sure your writing language is Arabic. – BiLaL Nov 7 '17 at 6:56

i found the answer here
http://www.personal.psu.edu/ejp10/blogs/gotunicode/2007/12/generating-arabic-hindi-curly.html

Word 2007

  1. Make sure you have activated an appropriate Arabic, Persian or other regional keyboard in the Windows Control Panel
  2. Open Word 2007, then click the circular Office icon in the upper left.
  3. In the new window, click the Word Options button in the lower right corner.
  4. Click Advanced in the left menu.
  5. Scroll to the Show document content section then look for the Numeral menu.
  6. Choose Context in the Numerals menu then close the window

    Note:
    Do not choose "Hindi" as your option unless you want this style in all documents (including English).

  7. In the Word document, when you switch to an Arabic keyboard, numbers will be in the Hindi style.

Is there any way to use Arabic as well as Hindi numerical in different part of a text.

This was very simple with Arabic-enabled Windows 98. Now with new version I really don't have a clue. I followed the above instructions but without success. Some suggested the following to change tables in a document into Hindi numerals, while leaving main text in Arabic numerical, but I failed to do it.

Try with the Replace function of Word:

  • Select a table and go to Edit → Replace → More → Special → Any digit → Format → Language → English
  • Place the cursor at "Replace with" → Format → Language → Arabic

The comma (,) needs to be replaced with an empty space (), and the full stop (.) with a comma (,). I'm not sure if these replacements need to be done before of after the language replacement, so that the digits remain in the correct order.

  • 1
    i dont understand what is the problem exactly? the method described above works , but u need to change the language to arabic to type in arabic numbers change back to english to type in english, please note that this is word-2007. other versions may work too. – Karim Jul 27 '11 at 13:06
  • You just saved me one week of hand work! – Bizhan Jan 24 '14 at 20:11
  1. Go to the top-left of the Word 2007 window and click the Office button.
  2. Go down and click the tab Word Options. You will get a new window titled Word Options.
  3. From this window select Advanced on the left side.
  4. Scroll down until you find the Show document content section.
  5. In the "Show document content" section you will find "Numeral". Select Hindi for the Arabic Numbers.
  1. Make sure you have activated an appropriate Arabic, Persian or other regional keyboard in the Windows Control Panel
  2. Go to the top-left of the Word 2007 window and click the circular Office button in the upper left.
  3. Go down and click Word Options button in the lower right corner.
  4. From this window select Advanced on the left side.
  5. Scroll down until you find the Show document content section.
  6. In the "Show document content" section you will find "Numeral". Select Hindi for the Arabic Numbers.

It is simple, just follow the following steps:

  1. Click on the Office button in the top left-most corner in Word 2007
  2. Click on Word Options
  3. Click on Advanced
  4. Scroll down to "Show document content" section
  5. In the "Numeral:" dropdown select "Context"
  6. Click on "OK"

protected by Community Mar 1 '15 at 12:04

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.