I have installed a Virtual machine.I use Virtual Box for the same. My host OS is Windows XP SP3. I have assigned it 500mb of Ram and it works fine. But my problem is that my Keyboard does not work in Ubuntu terminal whilst writing a source code.

When I use the arrow keys it gives me alphabets A B C D. And also when i press a . it acts as a backspace. I have a cordless Logitech Keyboard.I don't know why my keyboard isn't functioning inside the Terminal (& that to only whilst typing in source codes)

I have tried changing the Character Encoding but thats not helping.

Please help.

EDIT1 Somebody please help.

  • 2
    Might be worth explaining what application you are using to edit the specified source code. – Christoffer Madsen Aug 29 '10 at 12:49
  • What terminal are you using? What does echo $TERM print? – Nifle Aug 29 '10 at 14:22
  • It sounds like the terminal software is detecting the virtual hardware of your VM incorrectly. To fix it, you'll need to tell the terminal software which terminal type your virtual hardware most closely matches. In my own (limited) experience, that may mean trying them one by one until you find one that works. As for the steps to accomplish that, I'm hoping the more knowledgeable folks will chime in at this point. – boot13 Aug 29 '10 at 14:34
  • @ Nifle -yea right I have the one with the echo $ print . – Pavitar Aug 29 '10 at 15:07

vim editor works fine.However in vi editor my keyboard still acts funny.

So for me vim s a good alternative.


My guess is that your keyboard is fine. The arrow keys shouldn't function inside vi (and it's sad that they're enabled by default in vim). Also, there are different modes in vim, maybe you tried to type while in command mode rather than insert mode?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.