0

I have performance issues in VirtualBox, the quest operating system runs really slow and laggy.

The configuration:

  • Host: MBP 2019, 2.3 GHz 8-Core Intel Core i9, 16 GB RAM, MacOS Sonoma 14.2
  • Guest: Kali Linux, up-to-date, XFCE
  • VirtualBox: 7.0, Base memory: 8192 MB, 8 CPUs, Video memory: 128 MB, VMSVGA, Enabled 3D Acceleration. Guest addition is installed.

I tried different graphics controllers and also to turn on and off the 3D Acceleration. I tried different views: scaled mode, just scaling it down etc.

None of these seem to work. I also don't find good Google hits.

8
  • 1
    We need more detail on the Mac, because 8CPUs & 8GB assigned to the VM sounds a little over-generous, swamping the Mac itself, but tbh, VB is just slow compared to Parallels or Fusion.
    – Tetsujin
    Commented Dec 15, 2023 at 11:32
  • I added the info to the question.
    – SiGe
    Commented Dec 15, 2023 at 12:17
  • 1
    OK, with an 8-core HT CPU, you're OK to set 8 cores in the VM [assuming the VM can use them effectively]. 8 out of 16GB total RAM might be just a little over, I'd drop that back to 6. The rest will just be VB being slow, I'd have thought. I presume you're running the VM from the Mac's internal SSD, or something similarly fast?
    – Tetsujin
    Commented Dec 15, 2023 at 12:23
  • I am posting from a Kali machine here. I use well under 1/2 my host memory for my Kali machine. I use only 2 cores for CPU. The VM works well. Try assigning less host resources to the VM. I also use VMware instead of VBOX.
    – John
    Commented Dec 15, 2023 at 12:58
  • I tried with the suggested settings, but it is still slow. Especially when I start Firefox. But the slowing down is random. I have a feeling that is due to the high resolution that caused by the Guest Addition resizing, even though I switched to a fixed size. (I have this issue with other Linuxes too, but just after installing Guest Additions, but that I need in this case.) The difference is that I'm using VBox. I would like a free solution, VMware seems to not have a free plan.
    – SiGe
    Commented Dec 18, 2023 at 10:37

2 Answers 2

0

As David mentioned in the comments, I switched to a free VMWare instance that doing the job very well.

0

Have you tried booting with mitigations off? I seem to remember that VirtualBox did not handle well the Intel CPU vulnerability mitigation management (which, on a personal system, shouldn't be an issue).

They did get to fix that, but maybe on MacOS it still doesn't work as it should.

In the kernel parameters at boot,

mitigations=off

See also here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .