2

I'm facing a really strange issue. The issue is when I type the URL microsoft.com in my chrome it redirects me to google.com.

I have tried to clear browser cache, clear everything, uninstall/re-install Chrome, clear User_Data folder but nothing helps.

It's redirecting even I after I've set network to offline via inspector window.

When I see the network traffic for microsoft.com, for the Request URL (GET) is getting Status Code: 307 Internal Redirect (from disk cache).

Note: It works fine in Incognito mode.

1 Answer 1

1

Since it works fine in Incognito mode, this means that the problem is caused by an extension.

To find the extension, enter the following URL : chrome://extensions/, disable some extensions and restart Chrome and check. Continue until you find the extension that is responsible.

Note very well the source of the extension - if it is part of some installed product, that product should probably be uninstalled.

I also suggest to do deep antivirus scans with your antivirus and also with Malwarebytes.

7
  • I tried to disable all extensions, but the issue is still there
    – coure2011
    Dec 16, 2023 at 16:12
  • Does it work in another browser (Firefox, Edge) ?
    – harrymc
    Dec 16, 2023 at 16:56
  • yes,it works in firefox, edge, chrome incognito. It redirects to google.com even if the internet is off
    – coure2011
    Dec 18, 2023 at 3:23
  • 1
    Seems like an extension that is hidden from the extensions list, or something that is outside of Chrome. Does it happen when booting in Safe Mode with Network?
    – harrymc
    Dec 18, 2023 at 8:22
  • yeah it was an extension which I could not uninstall
    – coure2011
    Dec 19, 2023 at 9:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .