0

I have a network switch (Mersusys) of 5 ethernet ports in a room where I also can connect 4 devices. When I connect 1 PC and 1 Xbox Console everything is working fine.

      ________________________
     /          [Switch]       \
    /___________________________\
    |       |      |      |     |   
  Router  PC-1  Console 

However, when I add a 3rd or 4th device (a 2nd Xbox console and/or a 2nd PC) ALL of the devices loses their internet connection. I tried different ports and different ethernet cables, their green led lights do are blinking, I have disconnected and reconnected the Switch, I also have tried reinstalling/updating the Network card driver and a TCP/IP reset/DNS Flush, as suggested on another topic but none of that has fixed the problem. I also have tried setting the IP's of the devices manually so they have different IP addresses but also didn't work. I am not an engineer or programmer so I don't even understand what the problem could be, I would appreciate any help, thank you!

4
  • Try updating the firmware on the router. That may correct the problem.
    – John
    Dec 18, 2023 at 23:13
  • @John hmm didn't thought about that, the problem is that the router I have is from my ISP and from what I can see in the settings there is no option to update the firmware from my end. I guess if I can get a third-party router then maybe the problem could be fixed if the issue lies on the router, thanks for the suggestion!
    – Avith
    Dec 18, 2023 at 23:38
  • You might ask the ISP. Any ISP router I have seen supports more than 2 devices.
    – John
    Dec 18, 2023 at 23:40
  • PS love the ASCII art - always a big fan of people managing to include some in their questions and answers....
    – DavidT
    Dec 19, 2023 at 1:38

1 Answer 1

0

Are you sure you actually have a router?

I purchased a "cable model" (In my case a Motorola SB6183) you can usually tell the difference between a "Modem" and a "Router" as a modem like mine only has three connections:

  • Power Cable.
  • Cable connection.
  • A single network connection (RJ45).

It provides no routing capabilities - it just allows the device connected to it to get a public IP address.

I then connect the Cable Modem into a regular home Router (1 WAN connection, 4 LAN connections and WIFI) all my computers get private IP address i.e. an IP in the range 10.x.x.x or 192.168.x.x.

Its been a long time since I tested it, however when I last tried connecting a switch to the cable modem and multiple computers, only the first computer got an IP the second never received one.


There is another way to confirm if you actually have a router just open up a cmd window on the PC and type in ipconfig, if you see an IP address in the range 10.x.x.x, 192.168.x.x or 172.16.x.x you have a router, if you see a public ip address (something different) you either have a cable model or a router configured in bridging mode.


Assuming you actually have a Cable modem the simplest solution is just to buy a cheap (assuming you don't need WIFI) router and replace your current switch with the router.

4
  • I have a ZTE F689, looks like its both a modem and a router (DSL).
    – Avith
    Dec 19, 2023 at 4:03
  • Okay, can you check if it is in bridge mode (don't change anything just check if it is already in bridge mode) configuraraparelhos.claro.com.br/zte/f689/funcoes-avancadas/…
    – DavidT
    Dec 19, 2023 at 8:23
  • The one I have has a different user interface, and I have looked at all the options but there is no setting that can be changed between a "Router-Bridge" mode
    – Avith
    Dec 19, 2023 at 22:27
  • I would suggest you try the cmd check above to see if you have an internal IP (meaning its been NAT'ed) or an external IP which would confirm bridging is active. If your router is active (applying NAT) my answer is incorrect. If it is bridging I would suggest turning bridging off, if that is not possible the router suggestion from my answer may work.
    – DavidT
    Dec 20, 2023 at 8:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .