Using a live linux iso made with unetbootin, the aspire a515-48m gets as far as the grub menu, but refuses to boot linux from grub menu, from grub command line, and from uefi shell (running the .efi file directly) with supervisor password set in bios, with secure boot enabled (and efi file selected), or disabled, no difference.

I tried over 10 different linux distro iso images (including debian, ubuntu, altlinux, blackarch, opensuse, kali, parrot, gnoppix and others), and made a live usb using unetbootin, on 4 different usb sticks, and they cannot go past grub(however they boot fine on another laptop); removing quiet splash in the grub menu command to make it print debug does not help, as it fails before starting to print any debug.

  • 1
    Trying some of the kernel parameters / boot options like nomodeset would've been something I tried first. There's a handful of common ones, and a lot more, like A LOT LOT more, hundreds. See askubuntu.com/questions/716957/… If the computer could boot to grub, it should have a chance at booting linux further.
    – Xen2050
    Dec 25, 2023 at 8:04
  • nomodeset wasn't it, as that is one of the things I tried and one of the options in the grub menu has nomodeset; that is an interesting question, would be nice to know if any of these parameters can get it to boot without updating the bios - or what they did to make windows boot and not linux, so linux live iso images can adjust their parameters in the future to boot in such situations (or masquerade as a windows efi, whatever the cause is)
    – jmarina
    Dec 25, 2023 at 16:31

1 Answer 1


this answer is not for you if the live linux usb boots, and you can run linux (such as ubuntu) in memory, but you cannot install because it does not see the SSD or something like that - then you just press F2 during boot to go into the BIOS, go to the main tab, press control-s to reveal the hidden secret options, and set the sata mode to ahci.

this answer is for anyone who could not install linux on their a515-48m or similar model, because the live linux usb gets as far as the grub menu, and then returns to the acer splash screen and refuses to boot any linux distro at all.

Executive summary - a live linux usb does NOT boot on aspire 515-48m because the bios version is 1.00 and support for booting linux was added in version 1.21 - so you need to update the bios, then you can boot and install linux from a live usb. That is all; see below for details.

I figured it out, in the year 2023 AD, acer made it simple, easy and straightforward to install linux on the aspire a515-48m with ryzen5 cpu in 1 step which I describe here in the hope it may be useful to anyone else encountering this issue -

  1. the a515-48m laptop has uefi shell installed, referred to as "free dos" - the link is to the official pdf explaining the dos-like commands available to you in this shell

  2. the bios is version 1.00 which does NOT allow booting from a live linux usb, unless it is a windows iso; to access the bios, press F2 repeatedly while the computer is booting

  3. according to this acer post the bios does support booting live linux iso images starting with bios version 1.21, but the a515-48m has bios version 1.00 installed for convenience

  4. going to this acer link and typing a515-48m (or your model if it is different) you get a list of items you can download to upgrade it, such as drivers - scroll down to see the bios upgrade and download it; the bios upgrade is a zip file, containing an .exe file, with bios version 1.52 (at this time) which of course does NOT run in the uefi shell present on the laptop; it does run in windows

  5. next you go to download the windows 10 iso which is only 5.7 gigs or so; the reason you need this, is to upgrade the bios, so that you can boot a live linux usb, so that you can then use that to install linux;

NOTE - steps 5-13 show how to update the bios using the .exe provided by acer and a live windows iso/usb without installing windows; this worked; you can try to use a free dos live usb instead, but I haven't tried that so I don't know if the .exe provided by acer will run on free dos; if you try that, you can leave a comment if it worked or not;

  1. get unetbootin which enables you to make a live usb from an iso on linux, or rufus to do the same on windows, and put the downloaded windows iso on a usb; also make sure to unzip the bios upgrade downloaded above and copy the .exe file it contains to the usb as well;

  2. boot the acer a515-48m (or your model) with the live windows iso - you may have to press F2 during boot/post to go to the bios and select the usb as the first boot option by pressing F6 to move it up; going to the main tab and pressing control-s to reveal secret options does not help on the a515-48m, as it is already in ahci mode, the ssd works fine, and the options that appear are about a "bar"(whatever that is) and the touchpad, both are not related to the issue of not booting linux;

  3. surprise - the windows live iso boots fine on the acer a515-48m!(why would anyone ever need to boot anything other than windows?) no issues as with any of the linux iso images; on the first screen, use tab to select next, and press enter;

  4. on the second screen use tab to select repair your computer and press enter - do NOT select install windows!

  5. select troubleshoot and press enter

  6. select command prompt and press enter

  7. the live usb should be d:\, you can verify by typing dir d:\ and you should see the bios upgrade exe you copied there; if it is not d:, try dir a:\ dir b:\ dir c:\ dir e:\ dir f:\ to find it

  8. type d:\bios_152.exe (or whatever it is called on your usb) to run it - fortunately you can run the bios upgrade from the windows live command prompt without installing windows - the computer must be plugged in to an AC power source, because if the battery runs out during the bios upgrade, the computer will be bricked, as with a broken bios it can not start anything; so this step is critical - double check that you are running the bios upgrade for your specific model if it is not the a515-48m

  9. after the bios upgrade is complete, you can now turn off the computer by holding the power button down for about 10 seconds

  10. use unetbootin, rufus or your favorite tool to put your favorite linux iso on a usb to make it live, and now when booting the a515-48m surprise! it boots linux, and thus you can now install linux on it!

  11. if you should find that the mouse appears frozen when the linux desktop appears, note that there is a Fn key in the lower left of the keyboard, and one of the functions keys at the top, such as F7 or F10 has the function to freeze/unfreeze the mouse pointer; so if the mouse pointer is frozen, hold down the Fn key and press F10 or F7 once whichever it is or it may be a different function key, and then try to move the mouse

  • There are much better tools than the old Unetbootin. The multi-platform Balena Etcher is one of them. Nowadays, arguably, the best is the multi ISO Ventoy (also multi-platform) with which you only need to install it once to the target USB stick then simply copy how many ISO files can fit in the drive. Dec 22, 2023 at 13:12
  • 1
    And, nitpicking, BIOS as such doesn't exist in the consumer/"prosumer" market since 2012!!! What you - and probably the manufacturer - still call "BIOS" is actually UEFI. Dec 22, 2023 at 13:14
  • 2
    @ChanganAuto interesting, acer support refers to it as BIOS in the BIOS (UEFI) update download page; and the laptop which has no OS, only UEFI shell, is described as having "free DOS"
    – jmarina
    Dec 22, 2023 at 16:14
  • In many regions it isn't allowed to sell computers without an OS so the workaround is to bundle FreeDOS which is an actual OS, similar but unrelated to the proprietary MS-DOS (or its IBM exclusive PC-DOS counterpart). It isn't actually installed but some installation media has been included (again, this is just "smart" workaround). And, as commented before some manufacturer still use the old "BIOS" acronym, or sometimes "UEFI BIOS" but everything in the aforementioned market segments has been UEFI since 2012 and Windows 8. Is it clear now? Dec 22, 2023 at 16:26
  • 1
    you are misleading people by saying my answer is wrong and that it is not necessary to update the bios - it is! my answer describes the exact steps that solved the problem, as I actually did what I wrote; I did mention rufus but I do not use it, as it only runs on windows! the problem was it did not boot any live linux usb with bios ver 1.00!and I provided references in my answer, including where acer bios ver 1.21 adds support to boot linux; no ahci or ssd problem...personal attacks are not professional and have no place on this site...answers without detail clutter the site and teach nothing
    – jmarina
    Dec 23, 2023 at 19:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .