I am having issues with a device sending files to an FTP site on a Windows 7 Pro machine. I am not seeing the same issue between the same device and a windows XP machine or between the windows XP machine and the windows 7 machine. I am not familiar with Windows 7 (this is the first machine I have ever worked on) so I am looking for tips and techniques for debugging on the Windows 7 side.

The set up I have is:

  1. Cognex 5600 camera that sends out a small text file via FTP on an event basis. (Think of it simply as an embedded system generating data via FTP)

  2. Windows 7 Pro machine running an FTP site

  3. Windows XP machine running an equivalent FTP site, but also hosts a test program written in C# that can duplicate the data sent by the camera.

What I am seeing at the moment:

  1. I can point the camera at the XP system and send data at up to a 30mS cycle time with no errors reported by the camera.

  2. I can point the XP system at the Windows 7 system and emulate the camera and also send data at a 30mS cycle time with no apparent errors.

  3. When I point the camera at the Windows 7 system the FTP transmissions immediately fail and the camera reports FTP error 125 - Data connection already open, transfer starting. This occurs even if I slow my cycle time down to 500mS. When this happens no data at all shows up in the FTP directory.

From all this my assumption is that the camera is playing fast and loose with the FTP protocol and while XP is ignoring the situation, Windows 7 is clamping down and triggering an error.

Thus I need to peer under the hood and see what conversation is happening between the Camera and Windows 7.

At a fundemental level I will be playing with Wireshark but are there any Windows 7 specific features that I can employ to look at the data from another viewpoint?


I have had a fun time with wireshark and have detected differences in the FTP responses between the camera to Win 7 and XP to Win 7 situations. However I am not sure which network stack is working correctly and I have opened a case with the Camera manufacturer.

Here is the fun part:

  1. The XP system opens a connection to the Win7 system
  2. It sends a STOR command as the precursor to sending the data
  3. The Win 7 system responds with an ACK and a "125 Data Connection already open"
  4. The XP systems sends and FTP-DATA packet with the files payload

Compare with:

  1. The Camera opens a connection to the Win7 system
  2. It sends a STOR command as the precursor to sending the data
  3. The Win 7 system responds with an ACK and a "125 Data Connection already open"
  4. The Camera sends an ACK packet
  5. The Camera sends an FTP-DATA packet with RST and ACK, but no actual data
  6. The Win 7 system responds with "550 The specified network name is no longer available"
  7. The Camera issues an FTP quit request.

Any ideas as to who is right?

2nd Edit

I installed the 32 bit FileZilla FTP server on the Windows 7 box and the problem was solved. I still have no idea which FTP stack is at fault, but I am not concerned rigth now as I have a working solution. However I do find the situation worrisome.

migrated from serverfault.com Aug 30 '10 at 3:20

This question came from our site for system and network administrators.


What are you using for the FTP server? Just Windows' built in FTP server? Have you tried using an alternative, like FileZilla Server?

  • I'm using the Windows FTP stack. I haven't tried any other FTP servers and as per my edit I won't need to. – Peter M Aug 31 '10 at 16:38
  • 1
    I take my comment back. I just installed Filezilla and my issues went away! – Peter M Aug 31 '10 at 22:25
  • Glad that worked. If you figure out what was actually causing the problem in the first place, do let us know! – nhinkle Aug 31 '10 at 22:49
  • nhinkle - I am in no position to verify whose implementation of FTP is correct. And the manufacturers viewpoint is that their software isn't supported on Win 7 64 bit, so they are not going to look. My opinion is that someone is not correctly supporting the RFC and it shouldn't matter if the target is a Win 7 system – Peter M Sep 2 '10 at 0:01
  • Weird. Well I'm glad you managed to get it working, it's too bad they don't support it the right way though. – nhinkle Sep 2 '10 at 0:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.