4

I'm using a MSI Delta 15 laptop with an AX210 wifi+bluetooth built-in chipset.

My Bluetooth was working flawlessly until the last month or two. I use Bluetooth headphones and a Bluetooth mouse.

Now I have to use wired headphones because my Bluetooth just keeps dropping my headphones.

Now my mouse lags the hell out whenever I try to use it.

I've scoured the internet. It seems nobody has this specific issue. The Bluetooth has become unusable on its own.

I think I had a recent kernel update, 6.2.0-39 that might be the cause. I think it worked correctly on 5.15.0-91 so I tried reverting the kernel to no avail.

I tried various things like dmesg | grep Blue (it seems to load the correct firmware), disabling bluetooth co-existence on the chip, installing the newest 6.5.0 firmware...

  • Tried removing firmware files in /usr/lib/firmware to make it rollback. No dice.
  • Tried reinstalling all my kernels and kernel modules and etc... still no dice.
  • Tried installing linux-modules-iwlwifi-$(uname -r) and that actually caused my entire WiFi to go down.

The biggest issue is that there is no apparent error. It's not like the chip is unclaimed. It just doesn't work correctly.

It worked great a couple months ago and now everything lags in Bluetooth.

I'm not too sure how to troubleshoot this either since the device is claimed and "appears" to function normally. How do I troubleshoot this Bluetooth lag and get it to work correctly again?

0

1 Answer 1

5

Ok I opened my laptop and noticed that one of the antenna cables was actually popped off but still making contact with the outside of the plug. (Thank god there was a bit of kapton tape on top of it to stop it from rattling inside the laptop and shorting stuff.) So it probably had a ground but no signal on the one antenna. I popped the connector back in and it started to work as expected again!

TL;DR: Hardware issue now fixed.

2
  • 1
    Ahhh! Nice to see it sometimes is the barebones basics that cause issues. Jan 16 at 2:21
  • Thanks for the quality edits
    – TaiTair
    Jan 16 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .