0

TL;DR Speedtest on my pc (with ethernet) reaches 37MB/s, files download at ~1MB/s, while everything is normal on other computers on the same network. Tried reinstalling adapter&drivers, resetting network, different DNS, firewall disable, tested with Wireless adapter-same slow download speed...

I have a desktop with windows 10 that has the following problem: whenever I want to download a file, e.g. from google drive,mediafire,pixeldrain etc, the download speed is quite slow, around 1MB/s. My internet connection is 300Mbps (about 37 MB/s), and speedtest does reach this number on the same pc. My desktop is connected through ethernet, but even when I connect it via WiFi it still has the same issue. (All other devices work fine both on ethernet and WiFi)

Downloading games on Steam also seems to be affected: the downloads reach about 10-15MB/s (still half my bandwidth). This is not throttled by steam: at the same time, and downloading the same game, my laptop can download with max speed 37MB/s.

This is not a problem with my network, as the downloads reach max speed on any other computer I have, plus the speedtest reaches max speed on the same computer that has slow downloads.

I can also add multiple downloads from different sites, and they will download at the same time at 1-1.5MB/S: enter image description here enter image description here

I have tried:

  • Using different browsers, clearing Steam download cache, downloading in incognito
  • Using different DNS (default, cloudfare, google)
  • Reinstalling ethernet adapter (including drivers)
  • Resetting my network through Windows settings (Settings>Network&Internet>Network reset)
  • Disabling antivirus and Windows firewall

Desktop specs: i7 4790,16GB DDR3,a couple TB of SSDs (plenty of free space)

7
  • 2
    Are you using an Ethernet adapter or a Wireless Adapter? Tell us about the wireless access point if you’re using a wireless adapter? Give specifics about the adapter being used.
    – Ramhound
    Jan 16 at 12:25
  • Mainly I use Ethernet, I tested the problem also with a Wireless Adapter and it remained the same. Interestingly the file download speeds where about the same (~1MB/s) for both ethernet and the wireless adapter, even though the wireless adapter can only do 50Mbps on speedtest. It seems that file downloads are somehow throttled, no matter the bandwidth...
    – Arbiter
    Jan 16 at 13:16
  • 1
    Different sites just send downloads at different speeds... if you're positive your local network & internet connection can do max speeds then that eliminates a lot of variables & leaves only the internet & those sites
    – Xen2050
    Jan 16 at 13:40
  • I have tested the exact same sites&same file downloads at different computers, and the speeds are much much higher. I have also tried clearing cookies and a few different browsers. The downloads are always around 1-1.5MB/s, no matter the site or the browser or anything, while at the same time speedtest hits 300Mbps instantly.
    – Arbiter
    Jan 16 at 13:41
  • As a quick note, I'll also edit the question to add this: I can add multiple downloads and they'll all hover around 1-1.5MB/s
    – Arbiter
    Jan 16 at 13:49

1 Answer 1

3

It could be the setting for Maximum Transmission Unit (MTU) size needs to be optimized. To find the current settings and change them, to try different values that might increase throughput:

  • Press Windows, type cmd, press CtrlShiftEnter and accept UAC request to get CMD prom[pt as Administrator.
  • Type netsh interface ipv4 show subinterfaces and press Enter to list all MTU values. (On this Win 10 PC, all MTU values are 1,500 except for loopback, 4294,967,295.) Note the initial settings.
  • Test for the optimal packet size by entering ping google.com -f -l 1500, for example. If the message shows "Packet needs to be fragmented but DF set", then try a smaller value.
  • On this PC, the largest value that was not fragmented was 1,472. Add 28 to that value to get the optimal MTU setting for that PC ("20 bytes are reserved for the IP header and 8 bytes... for the ICMP Echo Request header."). 1,472 + 28 = 1,500, showing MTU on this PC is optimal.
  • Try changing a setting. E.G., enter netsh interface ipv4 set subinterface “Ethernet” mtu=1500 store=persistent to change the value for Ethernet MTU size to 1,500.

Another easy test is to make a boot USB for another OS, e.g., Ubuntu Live. Boot from USB (no need to install it on PC), and test internet speed and download speed. If the download speed is markedly better than from Windows, you know it's an OS issue, not hardware.

2
  • Optimal MTU size seems to be 1492. I changed it and there isn't any noticable difference... Doesn't the fact that speedtest reaches max bandwidth instantly guarantee that it's not a hardware issue?
    – Arbiter
    Jan 16 at 17:24
  • 1
    @Arbiter, likely, that's true. At this point, I'd try booting Ubuntu from USB and look at IP settings, and see if downloads are faster, and compare with those on Windows. BTW, another possibility - some third-party anti-malware suite could be slowing downloads, specifically. Never had a problem with Windows Defender, but perhaps another AV suite is checking too frequently. Jan 16 at 18:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .