0

I recently set up SSH access to my web servers on my Mac by following GitHub's documentation for Generating a new SSH key and adding it to the ssh-agent. After that, I installed FileZilla and the connections to my servers worked correctly. However, today I restarted my Mac, and tried to connect via SSH using the terminal, it asked me for the passphrase of my private key. I entered it and could connect. However, I still couldn't connect to my servers via SFTP on FileZilla. I tried running eval "$(ssh-agent -s)" and ssh-add --apple-use-keychain ~/.ssh/id_ed25519, but this did not help. I am either getting in FileZilla:

FATAL ERROR: No supported authentication methods available (server sent: publickey,gssapi-keyex,gssapi-with-mic)
Error:          Could not connect to server

or

Status:         Using username "root". 
Status:         Access denied 
Error:          Authentication failed.
Error:          Critical error: Could not connect to server

depending on which server I try to connect to.

If I make use of FileZilla's key import, converting the key file to a supported format (.ppk extension), and manually entering the passhprase in the prompt, the connections succeeds.

Why did FileZilla stop making use of the ssh-keygen (which is used fine through the terminal when using the SSH and SFTP protocols)?

Debug log excerpt:

Trace:          Pageant is running. Requesting keys.
Trace:          Pageant has 0 SSH-2 keys

I have always had "Normal" Logon type and echo $SSH_AUTH_SOCK prints /var/folders/sm/xxxxx/T//ssh-xxxx/agent.1133, as described here. I've tried using both Normal and Interactive mode, and both don't work anymore, but they used to work before the system restart. I also tried restarting my system again and this didn't help.

4
  • Have used the procedure as described in FileZilla Howto?
    – harrymc
    Jan 27 at 15:42
  • @harrymc Coincidentally, I just stumbled upon this article a few seconds ago and was reading it and was about to add that I use Normal logon type and echo $SSH_AUTH_SOCK has output. So I guess I have had everything set up correctly. However, it doesn't work anymore. I've just added this additional info to my post.
    – kataba
    Jan 27 at 15:45
  • What has changed, was there perhaps some software/system update? You could try to clean uninstall and reinstall FileZilla if it doesn't work any more. Note: Your problem and the message of "Pageant has 0 SSH-2 keys" reminds me very much of this old post.
    – harrymc
    Jan 27 at 16:00
  • @harrymc No system updates have happened since then. Pageant having 0 SSH-2 keys makes sense as I don't use PuTTY Pageant but ssh-agent. It is not clear to me why FileZilla doesn't attempt using ssh-agent just as macOS Terminal and iTerm2 do.
    – kataba
    Jan 27 at 16:09

0

You must log in to answer this question.

Browse other questions tagged .