I spent the night tweaking my computer running windows 7. I got a little performance gains but unfortunately, the Win-key keyboard shortcuts no longer work.

How do you fix them? What service requires them?

I'm mainly interested in the ones that move and re-size working window to half the screen.


Check this:

Go to Windows' "Ease of access center" by typing that exactly on START menu's search box.(or, just press WIN+U)

Find and click "Make the keyboard easier...".

Uncheck the box with "Prevent...." under "Make it easier to manage windows" if it is checked.

  • 1
    Thank you so much! For the longest time I thought these shortcuts required Aero (gross!), so I gave up, even though they were neat shortcuts. Then they worked on my computer at work even without Aero on. This was indeed the issue. :) – neminem Jul 13 '13 at 0:13
  • 2
    It was unchecked for me, had to check it, hit apply, then uncheck it and re apply to fix the problem. – grimurd Dec 20 '15 at 14:48
  • 3
    I would say this is an answer to a slightly different question. If 'prevent...' is checked then the windows do not snap, irregardless of whether it is the keys or the mouse that try to snap them. However, I am experiencing a differnt problem, in that the mouse can snap windows, but the window key+arrow keys cannot, And yes, my windows keys works in itself... (brings up the windows task menu, e.g.) – alexandre iolov Feb 10 '16 at 8:16
  • I had trouble with it. It didn't seem to work until I restarted the computer and THEN went and unchedked the checkbox. – Derek Aug 4 '16 at 10:32
  • Apparantely I too have what @Derek is having. Mouse snapping work, keyboard dont. It was working a while ago, but stopped just now. Something weird happenned. A bug, surely. – Maha Jun 24 '17 at 8:55

For me the culprit was ConEmu's icon in the system tray. Closing it or simply clicking on it made the keyboard shortcut work again.

PS: this never happened before I updated to ConEmu 160619 [64]

  • 3
    Thank you! This was driving me crazy, and the other solutions in this thread had no effect. Bug #479 - github.com/Maximus5/ConEmu/issues/479 – matt wilkie Jul 16 '16 at 1:23
  • 1
    @matt Thanks, this is what makes SE great! Great job finding and posting to the bug report also. – André Chalella Jul 16 '16 at 1:40
  • I had encountered the same in 161206 [64], had to uncheck all "Intercept keys" checkboxes to fix it. – m-dz Apr 13 '17 at 9:33
  • OMG, I would probably never figure that out! The first click (to minimize ConEmu) didn't help, but after clicking once more (to restore ConEmu), win + (shift) + arrows started to work again! ConEmu version 170517. Thanks a lot! – David Ferenczy Rogožan May 24 '17 at 17:04

That feature is called "Aero Snap" and here is a webpage about how to enable and disable it :) http://www.winhelponline.com/blog/enable-and-disable-aero-snap-docking-windows-7/

  • 3
    For anyone who runs into this issue in the future and ends up here, like I did: Aero Snap is not required. You can totally get these shortcuts back even in classic theme. The answer under this one is correct: it's the accessibility option under keyboard options to "prevent windows from being automatically arranged" that disables these shortcuts. – neminem Jul 13 '13 at 0:12

FYI - The full path to enable the windows+[arrow] function is: Control Panel\All Control Panel Items\Ease of Access Center\Make it easier to focus on task -- (keyboard works too as mentioned originally - they both take you to the same place).

Then you have to scroll down to heading that says "Make it easier to manage windows". This threw me off at first because the window doesn't look like there's any more content. So scroll down against your better instincts, then the full name of the "prevent" feature listed above is "Prevent windows from being automatically arranged when moved to the edge of the screen" -- make sure it's unchecked... I had to uncheck, recheck, uncheck to get my shortcut to start working again.


After following all of the advice listed (turning on and off all functions in the Windows "ease of access centre" I still didn't get it to work... until:

Reboot AGAIN after you toggle everything ON, APPLY, toggle OFF, APPLY

Then reboot.

Crazy, but it worked!

  • 1
    Answers are really intended to be complete solutions, with each answer contributing a different solution. Tweaks to answers should be done in a comment (requires a little more rep), or as a suggested edit. Just a heads up--"non-answers" tend to attract downvotes. – fixer1234 Apr 16 '16 at 22:40
  • This is really a comment and not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. Please read Why do I need 50 reputation to comment? What can I do instead? – DavidPostill Apr 17 '16 at 9:00

When I disabled the aero snap feature, which I did not like, the hotkeys for multi-monitor windows management quit working.

When I followed up to enable these (windows shift and arrow) hotkeys, I found "prevent windows ... edge of the screen" box was checked.

Unchecking "prevent windows ... edge of the screen" did re-enable the windows management hotkeys and unfortunately the snap feature which I did not like was also re-enabled.

So this setting apparently does more than disable the annoying snap-to feature, it also disables the useful keyboard shortcuts.


I had this issue but it was not because anything was disabled. Instead, I think windows explorer was in some kind of weird state where it was not recognizing the shortcuts.

Ultimately, I had to kill explorer.exe from the task manager (ctrl + shift + escape and find Windows Explorer or explorer.exe, and right-click -> end task). After you do this, it should restart to where you have your taskbar and everything back. If it does not, just re-open task manager, file -> run new task -> type "explorer.exe" -> click OK.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.