I have a setup in which I use a USB serial adapter + some application which sends and receives data using that serial usb. But this setup which works on a Windows, or even in a VMWare Virtual windows, does not work under WINE. IT transmits data but i cannot receive data. The cable and the applications are same as in the working and non-working scenarios. I guess The fact that the application works over the USB serial cable just as fine under Virtual Windows(VMware running on linux) by mapping /dev/ttyUSB to the com port, no external software/DLL needed, means it does not need any specific driver. (Am I correct in this assumption that application doesnt need any driver?)

(I also tried with a different setup(different USB serial adapter + different application under WINE, but even that does not work under WINE, but it works fine under WIndows/Virtual Windows)

How can I get it working under WINE?

Any pointers appreciated.

2 Answers 2


I know this question is old and that goldenmean has probably either worked it out or moved on, but someone else may stumble upon this question looking for an answer.

Wine doesn't automatically assign Linux serial ports to COM ports for Windows programs, but it can be done with a simple symbolic link. For Wine, in a command terminal you do the following:

$ ln -s /dev/ttyS0 ~/.wine/dosdevices/com1
$ ln -s /dev/ttyS1 ~/.wine/dosdevices/com2

Repeat as necessary to get all the ttySx serial ports you need assigned to COMx ports.

The commercial version of Wine called Crossover Linux may provide GUI tools for this or do it automatically, but I've never used it.


WINE is not an emulator or a virtualizer, WINE just implements Windows API in Linux. When you run a program under WINE, the program expects a serial port, but WINE doesn't provide them and hence the error comes. VMWare, on the other hand, virtualizes a full PC including the ports, and when the program requests the port access, it passes through the request to the ports on the host PC and hence it works fine.

To summarize, AFAIK it is not possible to have a program requesting ports run properly under WINE.

  • There is a similar setup, Application using USB serial port under wine, which works jsut fine under WINE. So its something more. Not what you summarized.
    – goldenmean
    Sep 2, 2010 at 9:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.