12

Periodically, when I am saving files, I get the error dialog Upload files On Save failed. Disable this functionality for this session?. Sometimes I accidentally select 'Yes'. How can I re-enable that functionality for the session without re-starting the IDE?

  • 1
    I've earned a tumbleweed badge for this one :( – Sonny Sep 8 '10 at 14:15
  • This is still an issue in 6.9.1 – Sonny Oct 19 '10 at 15:32
  • Still no changes in 7.2? – Alexey Aug 1 '12 at 8:08
  • @Alexey - I haven't gotten the error message in a long time, so I am not sure. – Sonny Sep 13 '12 at 13:15
13

I personally did not find any option to re-enable FTP Upload for session, but if you go to Project Properties and set in the Run Configuration "tab" the option Upload Files to "On Run" or "Manually", hit Ok, and then modify it again to "On Save", then the FTP Upload on save is enabled again.

Hope this was helpful!

  • As of 2017 this is the only method that works without having to restart project or IDE. – 25r43q Jul 4 '17 at 14:58
3

I close and open the project on netbeans 7.3. And syncing works again. This is faster than restarting the IDE.

  • This worked for me. Netbeans 8.0 – Omar Tariq May 19 '14 at 16:45
0

I've found a third solution that's related, and it's what I use now.

I use Atlassian SourceTree and its Git Flow implementation. While finishing hotfixes or releases, I actually don't want NetBeans to sync automatically. I've created a second configuration that I label "No Sync" for that purpose.

Simply switching to that configuration and then back to <default> re-enables syncing.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.