12

My Shift key doesn't appear to be broken, so this one's got me stumped: Looking online, I've been told the keyboard shortcuts for hiding and unhiding columns in Excel are Ctrl+0 and Ctrl+Shift+0, respectively.

The former of these works for me in Excel 2010, but for some reason the unhide shortcut does nothing. Has that keyboard shortcut changed, or... what am I missing?

20

Well, I'll be danged. Googling "Excel Ctrl Shift 0" brought me to this thread on the ExtremeVBTalk forum. That thread eventually comes up with this Microsoft KB article, revealing that, in Vista (and apparently Win7 as well), CTRL + SHIFT is hooked by the Regional/Language settings to change keyboard layouts. That functionality probably assigns the number keys to different layouts, so Win7 is swallowing CTRL + SHIFT + 0 and trying to change my keyboard layout (I don't have any non-default layouts set) instead of passing the shortcut to Excel.

After following the resolution in that KB article, the issue is fixed, and unhiding columns via the keyboard in Excel 2010 works as expected. To summarize, the solution is (in Windows 7):

  1. Open Control Panel -> Change keyboards or other input methods (Under Clock, Language and Region)
  2. Click the Change Keyboards button on the Keyboards and Languages tab
  3. On the Advanced Key Settings tab, select the Between input languages action and click Change Key Sequence
  4. Under Switch Keyboard Layout, set the radio button to Not Assigned (or one of the other options, if you need this feature to be available)

As for Dan's answer, no idea why the official list changed; after this fix the keyboard shortcut does seem to work, and the problem was related to an operating system setting, not Excel version...

  • +1, Good answer to your own question. The fact you got it to work makes it a bit bizarre that they took it out of the list of shortcuts. – Jarvin Aug 31 '10 at 21:44
  • It is a strange (and, given the question/answer here, ironic) oversight... – Dan J Aug 31 '10 at 21:48
  • +1 - Good job figuring it out. I tried it on XP which explains why I couldn't replicate! – JNK Sep 1 '10 at 0:08
  • 1
    And THIS is why we love Stack Exchange. Answers like this simply would not come out of the woodwork and into google search results more efficiently any other way. Thank you, Jeff Atwood! – Peter Nore Mar 21 '12 at 15:12
  • This in Windows 8.1 the same thing applies but the settings are arranged slightly differently. Disabling the input language default of alt + shift fixes it, pity the ctrl + shift + ) could not have been displayed in the settings, Windows needs a central shortcut config area. – Menuta May 21 '15 at 21:59
12

The shortcut for unhiding columns is: Alt+H, O, U, L

  • Thank you!! You just saved me probably an hour of sleeping :) – Philippe Jan 23 '14 at 3:19
3

In this official list of 2010 shortcuts the only row/column hide/unhide shortcuts are:

CTRL+SHIFT+(    Unhides any hidden rows within the selection.
CTRL+9  Hides the selected rows.
CTRL+0  Hides the selected columns.

In this official list of 2007 the row/column hide/unhide shortcuts are:

CTRL+SHIFT+(    Unhides any hidden rows within the selection.
CTRL+SHIFT+)    Unhides any hidden columns within the selection.
CTRL+9  Hides the selected rows.
CTRL+0  Hides the selected columns.

It looks like they just simply took it out.

EDIT: Looks like it is still there see djacobson's answer.

1

I've just been playing with this under UK Vista and it seems the default shortcut without tweaking the keyboard language settings is ctrl + shift + - (effectively ctrl + _)

1

IF you have any content at all in the hidden columns (which, I find is almost always the case), you can use the keyboard shortcut for AutoFit Column width. By autofitting the hidden columns, they are automatically shown.

Select at least the columns to the left and right of the hidden ones, enter Alt + H, O, I.

If the hidden columns are empty, you're stuck with the longer Alt + H, O, U, L already mentioned by Cliff Beacham.

0

You have to select the hidden column before you can CTRL + SHIFT + 0 to unhide. Easiest way is probably to put a cell into the Name Box (box at top left that lists the cell notation), then to CTRL + SHIFT + 0.

  • Didn't work. However, entering a cell reference, hitting Enter, and then CTRL + 0 does hide the selected column. It certainly appears that the Unhide shortcut is failing to work wherever the Hide shortcut works... – Dan J Aug 31 '10 at 21:07
0

Of course, Unhide is “U” on the context menu.  You should be able to invoke the context menu from the keyboard with Shift+F10 or .  On my laptop, I can get by pressing Fn+right Ctrl:

keyboard detail

Full-sized keyboards often have as a standalone key between right Alt and right Ctrl; see this and this.

So, use Shift+F10, U  or  , U to unhide.

0

Fix Ctl-Shift-0 for Windows 10

• Settings • Time & Language • Region & Language • Advanced Keyboard Setting • Language Bar Options • Advanced Key Settings; Action = Between input languages • Change Key Sequence . . . • Switch Keyboard Layout Radio Button should = Not Assigned

-1

In Excel 2010 there are shortcut keys for Hiding & Unhiding Rows / Column and they are working.

First check the settings:

  1. Open Control Panel -> Change keyboards or other input methods (Under Clock, Region and Language)

  2. Click the Change Keyboards button on the Keyboards and Languages tab

  3. On the Advanced Key Settings tab, select the Between input languages action and click Change Key Sequence

  4. Under Switch Keyboard Layout, set the radio button to Not Assigned (or one of the other options, if you need this feature to be available)

Now try this

  • Hiding Rows CTRL+(
  • Unhiding Rows CTRL+Shift+(
  • Hiding Columns CTRL+)
  • Unhiding Column CTRL+Shift+)
  • 1
    How does this materially add to the existing answers? – Dan J Mar 14 '14 at 18:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.