So, I'm running a Fedora 13 VM in VirtualBox under Windows Server 2008. I need to have access to the host drives from inside the VM, so I mount them. I use the C$ and D$ default shares. Here's the relevant portion of /etc/fstab:

//winhost/C$ /mnt/winc cifs user=joe,password=mypw,gid=171,file_mode=0664,dir_mode=0775 0 0
//winhost/D$ /mnt/wind cifs user=joe,password=mypw,gid=171,file_mode=0664,dir_mode=0775 0 0

It all works, and I can get to everywhere through the command line, but Linux balks on the pagefile.sys file in C:

$ ls -l /mnt/winc
ls: cannot access /mnt/winc/pagefile.sys: Text file busy
total 6165
-r--r--r-- 1 root win       0 May 18  2009 MSDOS.SYS
drwxrwxr-x 1 root win       0 May 12  2009 MSOCache
-????????? ? ?    ?         ?            ? pagefile.sys
drwxrwxr-x 1 root win       0 Jan 19  2008 PerfLogs
drwxrwxr-x 1 root win    4096 Aug 27 15:56 ProgramData
drwxrwxr-x 1 root win   24576 Aug 27 20:18 Program Files

No biggie. I still can do everything I need. But when I try to get to some file on drive C from a GUI application, the file dialog gets me an empty list when I navigate to /mnt/winc. Ditto for typing "nautilus /mnt/winc" on the command line.

And now, the oddest thing:

  1. I tried "nautilus /mnt/winc/Users": I get a brief flash of the correct contents of C:\Users and then it flashes back to an empty listing of C:.
  2. I tried "nautilus /mnt/winc/Users/joe/Documents": It works. I then navigate up, until I reach the mount point -- AND NOW IT WORKS! By the way, pagefile.sys is conspicuously absent from the icon list, which is OK really. File save dialogs in applications are similarly cured.

I'm going to reboot the VM to see if the bad behavior returns... Yep, it returns.

Shouldn't there be a way to tell mount.cifs to completely ignore such radioactive files?


Isn't there a set of virtualbox tools that you can use to do things like automatic mouse/keyboard grabbing/releasing, and filesharing? For example, under VMWare, I would select the client menu option "Install VMWare tools" and it would insert a virtual CD and install the RPM.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.