1

This problem arose suddenly. Whenever I try to write Arial in any Microsoft Office application (including WordPad) the text appears italic. Changing it to italic and back just does nothing, the text remains italic in both settings.

This is not a system wide issue with the font itself, for example webpages for which I set the font to Arial in 'Inspect Element' show up as expected. If I upload the same Powerpoint file to OneDrive and view it in the WebApp, it is also displayed normally. Printing the local file as PDF (I don't have a physical printer), however, also exports it italicised, even if viewed in different applications (Edge, Adobe Acrobat) or uploaded to OneDrive.

Searching the internet, I found several posts about a similar issue where Arial Black always showed up as italic, but I never found a solution to that either.

(Apart from the Office365 suite and WordPress, I don't think I have any other text editing programs installed that let me choose the font.)


Update: After having solved it, I believe that it also didn't render the webpage with Arial, but used some fallback that looked very similar (or maybe pulled it from somewhere online?). Nevertheless, it appears like it actually was a system-wide error and the Word WebApp used a remote version of Arial to render it correctly.

6
  • 1
    Meybe delete the font, restart, and install Arial again. See if that works. Arial works fine here on any of my Windows machines.
    – John
    Apr 2 at 21:37
  • @John I have not tried that yet, but since it works in other programs, I really don't think this would fix it. I'll give it a shot though.
    – PaulMndn
    Apr 2 at 22:26
  • @KJ you can't select specific fonts in Notepad. It looks as it should. Do you maybe mean WordPad? That has the same issue, as described above.
    – PaulMndn
    Apr 2 at 22:29
  • 1
    @KJ I don't quite understand those instructions, but I found a fix now. After PowerPoint decided to tell me that the font might not be installed and a placeholder would be used (it hadn't done that before or again) I looked into installed fonts where I found the fix I described in the answer. But thanks anyways :)
    – PaulMndn
    Apr 3 at 0:06
  • @John I tried that and found out that I can't even uninstall Arial because it is a system font and protected.
    – PaulMndn
    Apr 3 at 0:09

1 Answer 1

2

After some trial and error and more digging, I found a solution.

tl;dr / The Fix

The actual file was present in C:\Windows\Fonts, but the pointer in the registry was, for some reason, missing. Fixed by adding the correct registry entry:

At HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Fonts add a new String Value (Type REG_SZ) with name "Arial (TrueType)" and value "arial.ttf"

Change value to the filename as displayed in cmd dir C:\Windows\Fonts and (I'm not sure if strictly necessary) the name to the respective name of the font, as seen in the font preview window when double-clicking a font file, with an added "(TrueType)" if it supports it.

The Background

Looking at the fonts setting (in Settings), I saw that it was installed, but when navigating to the global fonts folder C:\Windows\Fonts did not list the default Arial font, but only its variations, such as bold and italic.

Notably, viewing this specific folder in Explorer does not actually show the folder's contents on the disk; it only shows correctly installed fonts. Looking at the folder from CMD with dir C:\Windows\Fonts shows the actual files at that location. CMD showed that arial.ttf was present but not installed according to the folder view in Explorer.

Looking at the registry for installed fonts, the entry for the default Arial font was missing. The issue was fixed by adding the missing entry as described above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .