0

I am trying to test IPv6 on a Hyper-V VM instance in Windows 10. IPv6 is enabled on my network, and working on my host machine (e.g, ping -6 ipv6.google.com is fine). However, in my VM, ping -6 does not work for global unicast addresses (link-local addresses to interfaces on my local network work fine) and I can not load ipv6.google.com in a browser. (All IPv4 addresses work fine on the VM, the internet is accessible.) Internet Protocol Version 6 (TCP/IPv6) is enabled in the VM with all addresses obtained automatically.

In PowerShell on my host machine, I get the following (with my Wifi's Name replaced with <Name>; 'HVS' is a custom name for a Virtual Switch created for my Hyper-V instance, configured for 'External network' with my wireless NIC):

host get-netconnectionprofile

Meanwhile my VM displays:

VM get-netconnectionprofile

Despite my NetworkCategory already being set to Private, I was hoping the 'Accepted Answer' to this question might help, but it seems resetting to Private has no effect on the value of IPv6Connectivity. I am presuming that IPv6Connectivity's value of LocalNetwork is the source of my problem (to be fixed by setting to Internet), but perhaps I am confusing cause and effect.

Is there a way to modify the IPv6Connectivity value directly in our network connection profile? Is there a step I missed to enable IPv6 support on my Virtual Switch? Could this possibly be an issue with my network adapter (this seems unlikely to me, considering everything else is working)?

3
  • My understanding is that the value is descriptive, not prescriptive – i.e. it only describes what access you have, and changing it by force wouldn't actually grant any access? Commented Apr 4 at 20:24
  • @u1686_grawity in this case, my question is definitely if there is anywhere IPv6 could be disabled for global network access (virtual switch, missing service, missed configuration step), given the results of the tests detailed in the question
    – shea
    Commented Apr 4 at 20:32
  • I am not certain about your last question but I looked at Hyper-V here and in the External, Internal and default switches, there is no IP type settings, just the NIC used. So it may be worth checking the NIC settings and the Access Point it connects to
    – anon
    Commented Apr 4 at 20:40

0

You must log in to answer this question.

Browse other questions tagged .