so I'm trying to install heroku and when I run it I get the following message:

/home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/restclient.rb:9:in `rescue in <top (required)>': no such file to load -- net/https. Try running apt-get install libopenssl-ruby (LoadError)
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/restclient.rb:5:in `<top (required)>'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/rest-client-1.4.2/lib/rest_client.rb:2:in `<top (required)>'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/lib/heroku/client.rb:2:in `<top (required)>'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/lib/heroku.rb:3:in `<top (required)>'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from <internal:lib/rubygems/custom_require>:29:in `require'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/gems/heroku-1.9.14/bin/heroku:6:in `<top (required)>'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/bin/heroku:19:in `load'
    from /home/brian/.rvm/gems/ruby-1.9.2-p0@seniorproject/bin/heroku:19:in `<main>'

I've installed the suggested library but it still doesn't work. Is this something I'm going to have to recompile ruby for? If so, what packages should I install beforehand?

3 Answers 3


Personally, I gave up on getting 1.9.2 running with Rails 3 & Heroku for the time being. However OSDIR mailing list mentions below instructions

$ rvm remove 1.9.2
$ rvm package install openssl
$ rvm install 1.9.2 -C --with-openssl-dir=$HOME/.rvm/usr
  • What version of Ruby is working for you? Commented Sep 2, 2010 at 19:50
  • @Reactor I'm using Ruby 1.8.7 p249 ( the one which came with Ubuntu) + Rails 3. Although do note I'm just learning Rails.
    – Sathyajith Bhat
    Commented Sep 2, 2010 at 20:32
  • Same here, actually. Installing the openssl-dev package fixed it for me. Of course, the next requirement for heroku is libreadline5-dev. We'll see if I've got them all after this. Commented Sep 2, 2010 at 20:34
  • This worked. I ran the calls described here, and installed libreadline5-dev and it all worked. Commented Sep 2, 2010 at 20:59
  • @Reactor5 Good to hear. Marking this question as favourite for future reference for me!
    – Sathyajith Bhat
    Commented Sep 2, 2010 at 21:36

the "package" call doesn't exist (maybe that's the old name)

You can do it more directly with:

rvm pkg install openssl
rvm reinstall 1.9.2 --with-openssl-dir=$rvm_path/usr

I completed the Installation process with rvm, ruby 1.9.2 and sqlite3. You gave up in the last step.

This worked for me after 2 days of wrestling with heroku:

sudo apt-get install libreadline-dev
cd ~/.rvm/src/ruby-1.8.7-p249/ext/readline

and then build the extension

ruby extconf.rb
make install

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .