2

I have English, Swedish, and Polish loaded on the system. I have created my own multilingual keyboard definition using the Microsoft Keyboard Layout Creator. It supports all three languages. I call it Swedish - EXtended.

I want to get rid of the Language Bar since I'm not going to switch keyboards.

enter image description here

I think I've done all you can do in Settings. I have currently two keyboards in Settings: Swedish QWERTY for English (United States) and Swedish - EXtended for Swedish; no keyboard for Polish. I've also modified Advanced keyboard settings.

enter image description here

In an earlier attempt I purged the US keyboard 00000409 and the British keyboard 00000809 from several entries in the Registry:

HKEY_CURRENT_USER\Keyboard Layout\Preload

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Keyboard Layout
    
HKEY_LOCAL_MACHINE\SYSTEM\KeyboardLayout\Preload
    
HKEY_USERS\.DEFAULT\Keyboard Layout\Preload

However, the result was not what I wanted. The Language Bar was still visible but I lost my multilingual keyboard Swedish - EXtended.

I'd like to understand what controls Language Bar in Windows and, in particular, how to get rid of it.

I know that I can easily remove the English (United Kingdom) keyboard by purging 00000809 in the Registry, but it doesn't solve all. I've also tried to add Swedish - EXtended and remove Swedish QWERTY for English, but it didn't kill the Language Bar.

EDIT: I have four Windows 11 PCs. I use Swedish - EXtended everywhere, but on only one I still have the Language Bar. I tried to copy the relevant Settings and Registry entries with no success.

1
  • I don't believe what you want is possible.
    – Ramhound
    Apr 22 at 16:29

2 Answers 2

2

I managed to disable the language bar on my Windows 11 by doing these actions :

  • In Settings, type "Advanced keyboard settings" into the search field and click it
  • In the Advanced keyboard settings window, enable "Use the desktop language bar when it's available"
  • Click "Language bar options" and set Language bar to "Hidden"
  • Click OK.

This disabled the language bar on the traybar. Setting only one of the above two settings is not enough.

1
  • It works. Thank you. My other PCs are not setup this way and have no Language Bar anyway. But I just accept it as a mystery of Windows 11. Apr 22 at 21:18
0

Have you tried simply setting the Language Bar to hidden?

Hide Language Bar

  • In Advanced Keyboard Settings, select Language bar options.
  • In the Text Services and Input Languages dialog, select Hidden.
  • Optionally, uncheck Show... options.
4
  • I've just tried it. The Language Bar is unchanged. The PC I'm using right now has no Language Bar and it is set to Floating in the popup. This doesn't solve my problem either. There is something more that controls the Language Bar. Apr 22 at 18:07
  • @John: Yes, I may. But it's annoying. I've solved it on three PCs but one wouldn't obey me. Apr 22 at 18:35
  • @KalleSvensson, my apologies: those settings work in Windows 10, on this PC, but Microsoft may have disabled that setting in v. 11, as it has done with some other settings. Apr 22 at 18:39
  • @John - Most Windows 10 solutions are applicable to Windows 11 but it's up to the author of the answer to verify that is the case.
    – Ramhound
    Apr 22 at 20:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .