33

Currently, Process Explorer's window does not show the process name:

link text

(When I run Process Explorer as another user, the column displays correctly.)

I have tried dragging all the column handlers, but the process name column still will not appear. Right clicking the column bar brings the Select Columns dialog, where the Process Name checkbox is checked and disabled.

How can I fix that? I figure the easiest way would be to simply clear the settings from my registry, but I can't find the relevant key.

7
  • Removed by bad answer, give me a few and I'll answer the right question :) – JNK Sep 3 '10 at 10:44
  • @JNK, no problem, we're all human. – badp Sep 3 '10 at 10:49
  • How did you manage to hide it? – Default Sep 3 '10 at 11:55
  • @Michael, the registry key which held that column's width got deleted. Hardly something you can do with the GUI :) – badp Sep 3 '10 at 12:13
  • exactly, that is what's so confusing :P did you really edit this yourself in the register and then ask it here or did procexpl just wake up one day and say "hey, I think you can cope without the processname, I'll fix it for ya'" :) Just wondering if you made some special action when it disappeared I guess, it is a strange bug/feature – Default Sep 3 '10 at 20:18
35

Using regedit, remove the key HKCU\Software\Sysinternals\Process Explorer, then start Process Explorer.

I would suggest to first Export the key, just in case.

4
  • A quick comparing shows the problem was with me was lacking the 0 value in the ` HKCU\Software\Sysinternals\Process Explorer\Process Columns\ ` key, for some reason. I can now just add the missing value it in the backed up and get my old config back. – badp Sep 3 '10 at 11:50
  • +1 Harry! I was driving. Badp, sorry for the bum answer earlier. – JNK Sep 3 '10 at 11:56
  • 2
    Adding 0 didn't work. Deleting the key worked. – Mark Jeronimus Jul 3 '16 at 8:14
  • If this happens regularly, you can use View » Save Column Set to save the state, and when the process name column vanishes again, use View » Load Column Set to restore the layout. – roeland Jul 21 '16 at 23:25
4

The following did the trick for me:

  • Close Process Explorer. Make sure that it does not stay open in the tray.

  • Adding a REG_DWORD named 0 and with a value greater than 0 (column width) to HKCU\Software\Sysinternals\Process Explorer\ProcessColumns

  • Modifying HKCU\Software\Sysinternals\Process Explorer\ProcessImageColumnWidth and setting it to a value greater than 0.

  • Incrementing HKCU\Software\Sysinternals\Process Explorer\ProcessColumnCount by one.

3
  • slight typo: PrcessColumnCount -> ProcessColumnCount – Mark T May 7 '19 at 15:55
  • @MarkT fixed... – CJBS May 20 '19 at 16:30
  • Actually the typo is in the app - the correct spelling is PrcessColumnCount. – G-Wiz Aug 30 '19 at 22:29
-1

Further to Andz answer ...

I did the following:

  • Close Process Explorer. Make sure that it does not stay open in the tray.

  • Add a new key of type: REG_DWORD with a value: 136 (column width) to: HKCU\Software\Sysinternals\Process Explorer\ProcessColumns

  • Modify key: HKCU\Software\Sysinternals\Process Explorer\ProcessImageColumnWidth and setting it to a value: 136

  • Increment key: HKCU\Software\Sysinternals\Process Explorer\ProcessColumnCount by one. Mine was 8 so I set mine to: 9 It stayed here after.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.