Pinnacle Studio 14 Importer crashes on Windows 7 x64, thus I'm unable to import videos from my camcorder. I've Googled around and it seems to be a problem with x64 support in the program, but there is no info if it can somehow be remedied with Compatibility settings, XP mode.

Further Googling got me this link, and none of the tips in site it links help. I've got no idea what ObjectDoct Plus 2 is (no a program or service installed by that name) which he claims causes the problem.

Is that ObjectDoct critical to Pinnacle Studio and how to get rid of it (or any other advice how to make Studio 14 work on x64).

UPDATE: 1) XP mode doesn't help as it doesn't handle Firewire, which is how my Canon HV20 must be connected to transfer HDV from tape. 2) I don't have that ObjectDock installed. 3) I don't wanna re-buy PS15 just to get this solved as PS14 should be able to do it.

3 Answers 3


If Pinnacle Studio 14 is not a real 64-bits program (although it happens to be "certified" on it), then you might be able to install and use it in XP Mode.

If you wish to go this way, here is an article to get you started:
Set Up and Use XP Mode in Windows 7

You might have some problems if you are using the Home version, so see this:
Workaround to Install Windows XP Mode in Windows 7 Home Premium and Home Basic

  • Thanks, but as said, XP mode (nor VMs in general) doesn't help as they can't handle the firewire connection from camcorder.
    – Tuminoid
    Sep 15, 2010 at 19:39
  • Is there a reason that you are on Win7 64-bits, such as having more than 4GB of RAM?
    – harrymc
    Sep 16, 2010 at 6:10

That is a typo, he means StarDock ObjectDock Plus 2.0... Do you have this? Try uninstalling it.

If XP Mode doesn't help, your best bet is to use a Virtual Machine, downgrade to x86 or wait for PS 15.

  • No, I don't have that dock app, never even heard of it before. I'd not like to go VM, as Pinnacle Studio uses graphics HW to boost effects rendering and VM doesn't support that.
    – Tuminoid
    Sep 7, 2010 at 3:31

Start >Control Panel > Administrative Tools > Services then: Look for two entries and make sure they are set to enabled and automatic They are:

Shell Hardware Detection and Windows image acquisition

This should help, if it doesn't I'm not sure what to tell you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.