-2

my usb drive is a acting very weirdly. when i connect it to my pc it makes a sound, meaning it recognized it. now 1 of 2 things would happen: it would show up in my file explorer with the name "removable disk", or it just won't show up at all. either way, disk management app won't load when i have the usb drive connected. but when i remove the usb drive, the app loads normally right away.

i tried to see drive manager to see if the device was even recognized, cuz at this point i was doubting that. the usb drive showed up under disk drives, but when i looked at the volumes tab, i saw that everything was empty.

Disk Information Disk: - Type: - Status: - Partition style: - Capacity: - Unallocated space: - Reserved space: -

i have no idea why all these are empty? my guess is the drive is corrupted.

there was a button at the button that said "populate" i have no idea what this does either, i had nothing on the drive to lose anyway, so i pressed it.

the window was frozen for a pretty long time after that. i thought it wasn't really doing anything because of how long it took, so i just closed it with task manager.

i opened file explorer and the usb drive showed up, but i cannot rightclick on it without crashing explorer.

when i restart it just didnt show up afterwards, and bro this is getting so annoying please help me

i also tried everything in the driver tab but nothing seemed to work

!! U P D A T E !!

THE USB DRIVE WORKED!!! i have no idea why, i thought it was dead. i left the drive for a day and then i was curious what would happen if i plugged it in.

then i was jumpscared WITH IT WORKING!!!!

before i plugged the usb drive, i was trying another hard drive and it said that are errors with this drive. i let it fix it, then i used it until the thought came to my mind

i am no pc expert and i am no one who knows what the hell happened, so i guess try what i did if you have this problem?

New contributor
Abdallah for yt is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
3
  • 1
    Could you format your message better so it is easier to understand? Sure it looks like the drive is failing. Do you have another device to try it or another operating system in that device?
    – golimar
    May 14 at 11:04
  • i have tried to connect it to another device, but i don't have any other operating system. May 14 at 11:41
  • It working now does not mean it is trustworthy. It only means it is working NOW. The likelihood it will fail again sooner than you may expect or want is higher than would be the case with another trustworthy drive. May 15 at 16:04

1 Answer 1

2

With what you describe, the drive has died.

The populate button is only to scan your computer and repopulate the list of disks/volumes/partitions. It took a long time because the drive isn't responding properly anymore.

You should replace the drive and restore from backups at this point.

5
  • so there is absolutely no way to fix it? i have nothing to lose in this drive. it's brand new May 14 at 13:05
  • 1
    A drive is not supposed to behave like it does to you. If its that new, you probably have warrantee. Get it replaced.
    – LPChip
    May 14 at 13:56
  • by brand new i meant unused, but i had it for a pretty long time. sorry if my wording is utter crap May 14 at 16:09
  • Well, it won't change much to the situation. The drive will still not work, and needs to be replaced if you want to use it.
    – LPChip
    May 14 at 16:11
  • rip :( that's really sad. i guess i'll see then May 14 at 16:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .