0

I'm having some issues with Windows 10. After fixing my temp INET folder which somehow was pointing at a different account, I've now found an odd issue.

If I type echo %localappdata% in CMD, it gives me my correct folder.

However, if I simply type "%localappdata% I get an error that states the folder is not recognized as a command. The listed folder is for the wrong account (a very old one I no longer use).

Where is CMD getting this 2nd environment variable from and how do I fix it? (same goes for %appdata% too!)

New contributor
user3714877 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
2
  • Can you attach some screenshots? May 14 at 13:19
  • 3
    I’m voting to close this question because the user mistyped a command, forgetting to quote a name with spaces (see comment to answer). May 14 at 13:46

1 Answer 1

1

In CMD, if you want to displays the variable or some text, you must use Echo command.
more info Echo /? in CMD.

echo %localappdata%
echo %appdata%

You cannot directly input it without Echo to read the output.

You can check All Environment Variables by type SET in CMD.

2
  • just figured I'm being a bit thick! cmd is taking the space in my new username as the end of the command, so I'm just getting an error message to that bit! I've been troubleshooting issues with office and onedrive and nothing is making sense, so I'm starting to clutch at straws! May 14 at 13:44
  • 1
    yeah, as much as they pretend otherwise, spaces in file paths will always cause needless pain. avoid them at all reasonable costs. May 14 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .