Putting this computer into sleep mode gives faint but noticeable beeping sounds synchronized with the blinking light. System and hardware info:

Device name DESKTOP-GG6AA6L
Processor   Intel(R) Core(TM) i7-4770 CPU @ 3.40GHz   3.40 GHz
Installed RAM   16.0 GB
Device ID   8dfdsfdsfds5
Product ID  0fdsfsdfsdfsdM
System type 64-bit operating system, x64-based processor
Pen and touch   No pen or touch input is available for this display

Edition Windows 10 Pro
Version 22H2
Installed on    ‎2/‎20/‎2024
OS build    19045.4291
Experience  Windows Feature Experience Pack 1000.19056.1000.0

What can be done to disable the beeping?

Trying from the cmd prompt as admin:

C:\Windows\system32>sc stop beep
[SC] ControlService FAILED 1062:

The service has not been started.

C:\Windows\system32>sc config beep start=disabled
[SC] ChangeServiceConfig SUCCESS


1 Answer 1

  • Command Prompt (Admin):
sc stop beep
sc config beep start=disabled
  • Registry Editor:
    HKEY_CURRENT_USER\Control Panel\Sound Find the Beep entry in the right pane
    change the value data to No.

Restart your computer for the changes to take effect.

To Restore default:
sc config beep start=auto, or change registry value to Yes.

  • trying now, thanks. Commented May 17 at 11:14
  • This will disable the beep everywhere. You should add to your post what this will do, because I would definitely not want the beep to be gone everywhere. Its like saying: I have a door, but my key doesn't work on the lock, and your solution is: Remove the door entirely. I'm giving a -1 on this answer for that reason.
    – LPChip
    Commented May 17 at 11:27
  • 1
    it didn't stop the beeping for me. Speaking for myself, I don't mind if the beep is disabled everywhere. I'll try again, running the cmd as admin, but looking for alternate solutions before firing up `regedit. Commented May 18 at 8:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .