1

Microsoft Word is glitching so bad due to hardware acceleration being on.

Unfortunately there is no option to turn it off neither the registry trick worked. Disabling HW acceleration from Windows is not an option as I do a lot of video editing and 3D stuff so I don't want to disable it completely.

Both Windows and Microsoft Office are up to date. Is there anything that can be done? Working on Word is giving me headache with all crazy stuff happening when typing.

I recorded clips then merged them in a single video in this YouTube link showing the issue.

More info:

  • Windows Edition: Windows 11 Pro Version 23H2 (OS build 22631.3447)
  • Microsoft Office: 2021 MSO (Version 2404 Build 16.0.17531.20120) 64-bit
  • Processor: Intel Core i9-13900K
  • GPU: Nvidia 4070ti

1 Answer 1

1

If you've determined that video hardware acceleration is definitely causing the issue in various versions of MS Word, here are a few things you might try.

  • If continually setting acceleration off and then on again through the various Windows control panels is a nuisance, take a snapshot of the Registry setting with acceleration on, and with it off, and run the appropriate script to flip that state. Depending on Windows version, according to Microsoft and to MiniTool, the DWORD value might be at:

    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Avalon.Graphics\DisableHWAcceleration
    

    or

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\GraphicsDrivers
    

    Note that one might need to log off and then on, or to restart, for the change to take effect.

  • Run MS Office in a virtual machine, such as VirtualBox, set with HW acceleration off.

  • Try a different productivity suite, such as free LibreOffice. The Writer application can create, edit and save in all MS Word formats. If it doesn't work better than MS Office, just uninstall LibreOffice.

1
  • The registry option didn't work. Couldn't find "DisableHWAcceleration" DWORD so I created it my self and set it to 1 restarted my computer. Problem Persist. I've tried other registry workaround but none has worked. Could be a Win11 thing idk. Commented May 18 at 9:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .