I've recently downloaded ffmpeg and I need to run it through command line. I'm not able to do that because I don't have admin rights. How do I work around that?

  • Determine the path. Then c:\completepath\ffmeg Adapt this to your needs
    – anon
    Commented May 21 at 12:59
  • 3
    Are you positive you cannot create a user variable? That typically can be done. However, the simplest way past not having Administrator rights, is to simply use the full path to the executable. If that still doesn’t work have the Administrator add the path to the executable to the system PATH variable instead
    – Ramhound
    Commented May 21 at 13:01
  • 1
    1. title talks about PATH 2. body talks about admin rights - ??
    – Kissaki
    Commented Jun 5 at 17:42
  • 1
    What have you tried? How does the issue surface/show?
    – Kissaki
    Commented Jun 5 at 17:42
  • Not having admin rights I'm guessing this is a company/employer's computer, or a school computer. Have you spoken with the IT staff responsible for supporting your device? They can get this all set up for you, if you are allowed to do it, or it is a requirement for your work. Commented Jun 13 at 16:11

2 Answers 2


You should be able to change the Path for your own account with Windows Environment Variables UI, or set the variable explicitly from CMD.EXE to change your Path default value:

setx Path "%Path%;c:\Path\to\the\ffmpeg.bin.dir"

The new value applies for next session of CMD.EXE, not current. Then you should be able to Windows+R to run exe found within the new path values.

  • Having re-read your question, perhaps you mean you don't have admin rights to install, in which case ignore the above.
    – DuncG
    Commented May 21 at 14:01

You don't need admin rights to change your own user variables. Press WINDOWS + R keys to open run command. Type: sysdm.cpl end press ENTER. Go to Advanced tab, Environment variables, and at: User Variables add the path to ffmpeg (usually inside a bin folder) inside the "path" user variable.

An other option is to always use the full path where you stored ffmpeg something like %userprofile%\downloads\ffmpeg\bin\ffmpeg.exe -i input.mp4....

Not the answer you're looking for? Browse other questions tagged .