3

OS: Win 10 home
ISP modem/router: Actiontec T3200M
Subnetwork router: Asus RT-N66U

T3200M Lan
Mode: wireless router
Lan IP: 192.168.1.254
Mask: 255.255.255.0
IP pool: 192.168.1.64-253
Dhcp reservation for subnet router: IP: 192.168.1.65 via lan port 1, unbridged

RT-N66U
Mode: wireless router
Wan ip: 192.168.1.65, via Wan port Lan ip: 192.168.0.1
Mask: 255.255.255.0
IP pool: 192.168.0.10-100

The problem:
Devices on T3200M 192.168.1.x (ports 2-4, or wireless) cannot ping devices on RT-N66U 192.168.0.x, but devices on RT-N66U can ping devices on T3200M.

I want my 2 laptops ethernet connected (ports 2&3) to T3200M able to 2 way file share with home theatre PC and desktop PC on RT-N66U.

Note: the T3200M does not have routing rule functionality.

Further info: I have dlna server on 192.168.0.13, which has 23424 service port forwarding rule on RT-N66U (for internal network) and also rule on T3200M (for external access). These rules work fine.

I also have printer on 192.168.0.10, with a 9100 port forwarding rule on the RT-N66U. It works fine, I can print from computers attached to either router.

3
  • Based on your description you have no devices on the 192.168.0.x subnet only 192.168.1.x you should make sure DHCP is disabled on one of those devices. You might have made a typo in your question body.
    – Ramhound
    Commented Jun 13 at 21:32
  • There are 4 ethernet devices and 4 wireless devices on the 192.168.0.x, which does have dhcp on (and needs to stay on). Several devices do have static ip Commented Jun 13 at 22:41
  • 1
    When I suggested disabling DHCP I mean on the network devices not the clients, in other words, it sounds like you have multiple DHCP servers configured in error if they are all on the same subnet. I would again verify your description.
    – Ramhound
    Commented Jun 14 at 0:51

2 Answers 2

6

This is quite normal, for several reasons:

  • Your wireless router by default uses NAT, so it presents all traffic coming from its own local network under one single IP address. So when a device on your wireless network (using an IP address such as 192.168.0.10 for instance) talks to any device not on that same network, it will appear to the destination device as if it was coming from 192.168.1.65. This enables communication from the outside to the inside, but not the other way around. A device on the external network cannot reach 192.168.0.10: it needs to talk to 192.168.1.65 instead, and 192.168.1.65 needs to know which internal device to send it to (NAT forwarding rules).

  • If you just disable NAT, it can work better, but there's still an issue: all your devices on the 192.168.1.0/24 network only know a single default gateway, the one which goes to the Internet. They don't know (and neither does that gateway) that traffic to 192.168.0.0/24 needs to be sent to 192.168.1.65. You can address this by adding routes, either on all devices, which can be difficult and cumbersome, or on the Internet-facing router, if it allows it, which is uncommon on consumer-grade routers.

  • Many services (such as discovery of other computers, servers, printers on the same network) rely on the devices being on the same network (the same "broadcast domain"). As long as you have routing in between, it won't work.

The solution, if your router allows it, is to set it to Bridge mode or Access Point mode rather than Router mode. Note that this is different from the Wireless Bridge functionality. It's simply telling the router to work as an Access Point (AP), not a router: the wireless and wired networks are actually the same network, and the device acts like a switch (L2), not a router (L3).

You say the manual matching your device is that of the RT-N66W. See page 82 of that manual:

To set up the operating mode:

  1. From the navigation panel, go to Advanced Settings > Administration > Operation mode

  2. Select any of these operation modes:

  • (...)
  • Access Point Mode: In this mode, the router creates a new wireless network on an existing network
  1. Click Apply

Now all your devices will be on the same 192.168.1.0/24 network, and should be able to talk to each other.

Note that you may need to disconnect/reconnect (or reboot) the devices for them to pick up their new IP settings (IP and default gateway).

2
  • Looks like I have 2 choices, a) ap mode the rt-n66u and change dhcp reservations and devices with static ip to reflect loss of 192.168.0.0 / 24 network b) buy a 5 or 8 port switch to attach to rt-n66u and do a small amount of cat5 rerouting. Commented Jun 14 at 16:12
  • @GeraldManweiler I’m not sure I understand how adding a switch would help you in any way. Note that if you want to keep the same IPs, just configure your main router to use the 192.168.0.0/23 network so it covers both exiting networks.
    – jcaron
    Commented Jun 14 at 20:00
3

Having reviewed the manual for your router, this issue is due to the nature of Consumer-grade Internet access routers. In particular there is no documented option to disable NAT/SPF. In general Internet access routers are not suitable for use as interior routers (though some more advanced models can be used that way).

Just as when used as a Gateway router, consumer routers will block all traffic coming in, unless it is part of a connection being solicited from inside the LAN. Thats why you can ping LAN to WAN (the outer network), but not WAN to LAN.

Using this router (unless there are undocumented features in the WAN configuration of the management console) you will not be able to make the two networks work together bi-directionally.

Your options are:

  1. Create port forward rules for services on the inner network you want to consume on the outer network (this is likely insufficient for your needs, but I'd be remiss if I didn't mention it).

  2. Create a VPN or SSH server on the inner network (and forward ports for it) so that systems on the outer network can connect to the tunnel and route traffic through that server.

  3. connect the routers LAN to LAN so that its all one network (192.168.1.x) [note you must disable DHCP on the inner router].

  4. put the inner router in bridge mode. this is effectivley the same as #3 above.

  5. replace the asus router with a more capable model that lets you disable NAT and operate properly as an interior router.

1
  • Comments have been moved to chat; please do not continue the discussion here. Before posting a comment below this one, please review the purposes of comments. Comments that do not request clarification or suggest improvements usually belong as an answer, on Meta Super User, or in Super User Chat. Comments continuing discussion may be removed.
    – Mokubai
    Commented Jun 14 at 19:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .