I used the Boot Camp Assistant app on Mac OS 10.6.4 to create another partition. Then I erased the partition with Disk Utility instead of using Boot Camp Assistant to erase it.

Now rEFIt gives me the option to boot Max OS X, but also an option to "Boot Legacy OS from HD". What is it referring to?

My computer has only one physical drive and is setup the default way when doing a fresh install of Snow Leopard.


/dev/disk0 -- GUID_partition_scheme
/dev/disk0s1 -- EFI
/dev/disk0s2 -- Apple_HFS Macintosh HD

After removing the Boot Camp partition with Disk Utility, I thought that it might not have removed some sort of boot info from the drive because I didn't use Boot Camp Assistant, so I used Boot Camp Assistant again to recreate a partition and then used it to remove the partition.

I blessed Mac OS X and rebooted and then re-blessed rEFIt.

Still no dice. Any idea as to a solution? If I do a backup and then reformat, will the problem still exist because of a file that I restore afterwards? I don't want to do that just to see if it will work--I'd rather know via some existing documentation before taking that step.

Thanks in advance.

3 Answers 3


Warning: Please be sure you have a good idea of what exactly is happening before following any advice that I write here. This may be risky! Please do a bit more Googling before pressing ENTER on a Linux terminal. :)

I had this same problem after I removed a partition containing Windows 7 using Disk Utility. The problem in my case was that the Windows 7 partition was removed, but the Windows boot loader installed on the Master Boot Record (often denoted MBR) remained. To remove it, use dd as in the example below.

EXAMPLE: If your Windows boot loader is installed on the MBR of your sda drive, from a Linux terminal run: (WARNING, DON'T BLINDLY TYPE THIS WITHOUT READING THE DESCRIPTION ABOVE:) sudo dd if=/dev/zero of=/dev/sda bs=440 count=1

The dd command is also helpful if you have an extra GRUB boot loader installed somewhere. For example, I mistakenly installed a GRUB boot loader on my second hard drive both in the second hard drive's MBR and in the second hard drive's first partition. rEFIt listed both of the boot loaders, even though only the one installed on the second hard drive's MBR worked. So to remove the extra GRUB boot loader on the first partition of the second drive I also used dd as below.

EXAMPLE 2: If you have an extra GRUB boot loader installed on a partition, in this example partition sdb1, from a Linux terminal run dd as in the example below. (Notice the "of=..." changed and the "bs=..." changed from the first example.) (WARNING, DON'T BLINDLY TYPE THIS WITHOUT READING THE DESCRIPTION ABOVE:) sudo dd if=/dev/zero of=/dev/sdb1 bs=446 count=1

I know this is an old question, but it was never really answered. I hope this helps many people who were led to this page while searching for this problem. God bless!

  • Thank you! This has worked for me on a a Macbook Air (which has a hybrid MBR - yikes) without damaging anything. :) The "boot legacy from HD" option is gone and OSX/Kubuntu boot just like usual. I assume you have this tip originally from Rod Smith who is made rEFInd, right? Executing sudo dd if=/dev/zero of=/dev/sda bs=440 count=1 in Kubuntu was all I needed. I should mention that Kubuntu efi boots on my Mac. If it would boot via BIOS legacy, the boot would probably break, but then I also wouldn't have had this problem in the first place... Jul 22, 2013 at 7:40

If you're only using OS X, just remove rEFIt and re-bless the OS X boot disk. If you still want to use rEFIt for some reason, just reinstall it.

  • If by "remove rEFIt" you mean delete the /efi folder at the foot of the HD (where it resides), then I did what you said. The "Boot Legacy OS from HD" option is still there after re-installing rEFIt.
    – jsejcksn
    Sep 6, 2010 at 4:50

I had not received an answer yet so I just took the dive and:

  1. Used Time Machine to backup my Mac to an external firewire HDD
  2. Booted from the OS X install disc and reformatted my internal HDD as a single HFS+ volume
  3. Restored my OS from the Time Machine backup
  4. Re-blessed rEFIt

Now it only shows the option for Mac OS X. I think the problem came from partitioning the drive with Boot Camp Assistant and then removing the partition with Disk Utility instead of Boot Camp Assistant.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .