I've just built my first system, and it works fine... until you plug in a graphics card (I can boot into Windows 7 easily using the onboard graphics).

I've tested it with two separate cards now, and I still haven't had any luck. With a graphics card installed, I briefly see the POST screen, then one of three things happens: Either the screen goes completely black and the computer idles, I get a cursor in the top left corner that does nothing, or a vertical line of capital "D"s is printed down the left side of the screen. I can access the BIOS before this, but if I try to go into any of the menus it freezes and I have to hold down the power button to restart.

It only beeps once when I turn it on, which apparently means everything is fine.

I disabled the onboard graphics before installing the card, but still had no luck.

The motherboard is used (it's a hand me down from my brother), but I know it works fine since I can boot into windows using the onboard graphics, and he was using it with a graphics card as recently as a week ago (he's out of the country, so asking him if he ever had problems isn't an option).

System information:

  • Gigabyte GA-MA790GP-UD4H motherboard
  • Sapphire Radeon 5670 512MB GDDR5
  • 2Gigs DDR2 ram Athlon II x2 3.0GHz
  • 430-Watt Antec Basiq power supply (meets the graphics card requirements)
  • Windows 7 Home

I really hope someone can help.

  • Have you got it on full POST rather than fast boot or whatever? Is the slot enabled in BIOS settings? Are you absolutely certain the card works, like plugged in to a known good system and shown to work (could be a bad batch at supplier for example)? Have you enabled the onboard graphics, booted Win7/Ubuntu and seen the card is detected in the device manager? – pbhj Sep 24 '17 at 9:41

I believe your problem is with the power supply. According to Antec's website the maximum rated output is 360W. And since that card doesn't have an external power connector it is pulling from the same rail as the motherboard.

If you want to test this theory purchase a better power supply from a retailer that will allow you to return it if doesn't meet your needs.

I would suggest using a power supply certified by AMD.

  • Are you sure about that? Max power consumption under full load for this graphics card is 259W, my processor is 65W... The hard drive/DVD drive and fans can't be drawing that much, can they? – Joel Sep 5 '10 at 19:04
  • The only way to know for sure is to test it with another power supply. According to your motherboards manual: • To meet expansion requirements, it is recommended that a power supply that can withstand high power consumption be used (500W or greater). I f a power supply is used that does not provide the required power, the result can lead to an unstable or unbootable system. – Chris_O Sep 5 '10 at 19:18
  • Okay, just swapped out the power supply for a 750W one. No luck. – Joel Sep 5 '10 at 20:31
  • I understand your frustration. I build computers and know how difficult it can be to pinpoint problems like this. Have you tried resetting the motherboard bios by pulling the cmos battery? Also are you running the latest bios from Gigabyte? – Chris_O Sep 5 '10 at 20:57
  • I've tried resetting the bios with no luck. I don't know if I'm running the latest bios, but the changes in the updated versions they have on their website don't say anything about graphics cards. – Joel Sep 6 '10 at 16:21

I would think that the GPU is bad, contact the retailer you got it from and submit an RMA request to get a replacement.

Before doing this try it in a different machine to make sure it is the card.

You can also try and reset the BIOS through either:

  • Removing the BIOS battery from your mobo and replacing it after a minute
  • Locate the jumper located near the battery and reset the CMOS that way.

Read your motherboards manual for instructions.

  • Definitely not the GPU - this is the second card I've tried. I returned the first one to the store where I got it - They tested it and it worked fine. Resetting the BIOS is going to be my next step though. – Joel Sep 5 '10 at 18:04
  • Let me know how resetting the BIOS turns out for you then I'll put my thinking cap back on. – Sandeep Bansal Sep 6 '10 at 0:19
  • No luck with resetting the BIOS. I've also tried using the card in the PCI-E 8x slot, but the system doesn't even detect it there, even if I tell the bios to initialize it first. – Joel Sep 6 '10 at 16:22
  • Have you made sure you put the power adapters securely in the card? Try updating your BIOS through this link download.gigabyte.us/FileList/BIOS/… and see what happens. – Sandeep Bansal Sep 7 '10 at 16:32
  • @Sandeep-Bansal that card doesn't have power connectors. – Chris_O Sep 7 '10 at 17:27

Although relatively unlikely, it could be that the PCI-E slot is faulty. This happened to me and all the research I have done suggests that if your problems are NOT due to:

  1. Not plugging in the 6+2 power connector to your power card (NOTE: Some cards may not even require external power)

  2. Not having a sufficiently beastly power supply unit. (NOTE: I ruled this out as my power supply was 550W, on a system that barely required 300)

  3. RAM - is it seated correctly? It may take some force - more so than novice builders expect.

  4. PCI-E - is that seated correctly as well?

... if it NOT due to the above, then it is possible, and at that point also probable, that it is due to a faulty PCI-E slot. I would RMA.

  • Thanks for the help. I've actually gotten it to work since I posted this question. Unfortunately, I have no memory of how I fixed it (this question was posted three years ago ;-) ) – Joel Dec 28 '13 at 2:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.