I put a clean copy of Windows 7 on my Slave HDD but now I want to remove my primary.

The issue, as I understand it, is that the MBR is on the primary and when I take it out I therefore can't boot. To be clear, with only the Windows Seven HDD connected I cannot boot into windows but with my primary connected I can boot fine.

What I want to do is write a new MBR to the secondary hard disk after making it primary. To achieve this I boot off my Windows 7 disk and then run;

bootrec /RebuildBCD
bootrec /FixBoot
bootrec /FixMBR

But for the former two I get the following response;

Element not found

The drive that is connected definitely contains the Windows 7 install and is found by the RebuildBCD tool, when I confirm that I want it added I get the element not found exception. Has anyone else had this issue?

  • How did you install Windows 7 onto the secondary drive?
    – BillP3rd
    Sep 5, 2010 at 20:10

2 Answers 2


I have the same problem.

So far I tried unsuccessfully using these steps:

Step 1. Automatic repair! I let the Windows 7 DVD do the trick alone. However, the status report does not show anything repaired, and the computer restarts after running the tool.

Step 2. Fixing the boot sector manually! Similar approach used here (RebuildBCD, FixMRB & FixBoot) but I tried first with boot the boot tool on de DVD first. Even when the output said "successful", it could not boot.

Step 3. Disconnect everything! I just connect the SSD disk (new) and the DVD reader. Try again the Step 2 but it did not work.


Step 4. Make the disk bootable! Apparently, the disk partition where I installed Windows is not flagged as "bootable". The installation just 'copied' the Windows into the drive without actually making the partition active and relied on the other disk to boot up. I solved the problem by:

Diskpart select disk #d

select partition #p

active (setting the partition active is making it bootable)

Reboot and use the DVD repair tool (Step 1)


Are you getting 'Element not found' when the old disk is removed?

I would imagine you could simply remove the original MBR from the equasion entirely, and do the 'Repair my system' from the MS DVD.

This way the DVD sees there's an OS missing a MBR, and would just make one.

  • As I said, the drive that is connected definitely contains the Windows 7 install when I boot from the DVD. My assumption was the same as yours but when I have only the slave installed (Which contains the OS) I get the 'Element not found' exception. This is in spite of the RebuildBCD identifying a windows 7 install on the HDD.
    – gav
    Sep 12, 2010 at 17:54

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .