I recently have problems when trying to log in to my MSN account from OS X Leopard. I tried to add my account to Adium, where it worked the 1st time and then on the following boots it just keeps trying to connect without any success. So I installed Messenger:mac in hope it would work better, but the same issue. The 1st time it worked and now, when I wanted to launch it again, it gives me the error message:

Sign in to Microsoft Messenger failed because the service is not available or you may not be connected to the Internet.


Does no one have an answer to this problem?? It still doesn't work. In the meanwhile I tried the following things (with no success):

  • complete reset of Adium
  • upgraded to the latest beta version of Adium 1.4.b8
  • downgraded to Adium 1.3.0 (due to a forum post which claimed MSN works on this version)
  • Tried to access with different Windows Live accounts (no success while they work on Windows)
  • Completely disabled the Firewall
  • Tried to access web messenger (at people.live.com) which worked just fine (also services like Meebo work).

What I found is that if I start Adium with all Live accounts disabled and I log in to webmessenger, then it notifies me that I'm signed in at 2 places. If I shutdown Adium it doesn't... ?!?

  • 1
    Do other chat services work? aim? yahoo? gchat? – Troggy Aug 5 '09 at 15:28
  • yes, Google Talk works without problems – Juri Aug 5 '09 at 21:05

I am not sure what the problem is with Adium, but Messenger for mac does not support the "http fallback" feature that the windows client does. This essentially means that it the firewall has the outgoing IM ports blocked then you won't be able to use Microsoft messenger for mac.

To solve this problem, I just just Adium ... here is what I would recommend.

  1. Make sure you are on the latest version of Adium, some specific versions have connection issues in some circumstances. You might want to check the release notes.

  2. Try web messenger, this way you will know if there is a problem with your account.

  3. Try and connect on a different network and see if there is a firewall getting in the way.

  • actually I tried to completely disable OS X's firewall and also on different networks. No difference. Just downloaded the latest version of Adium 1.3.5 and again, no success. It keeps on connecting...also with a different MSN account. I have no clue what I'm doing wrong that it works for other people.. – Juri Aug 6 '09 at 11:27

As a workaround I would suggest using an online client such as Meebo.


I just "fixed" the problem. The problem was to check the setting "Connect via HTTP". I can't remember it was set before, but with it it seems to work just fine.

Here's the according link to the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.