KeePass 2.12 - Turning off hidden password - When I open an entry, the password is disguised by asterisks. How do I turn off this feature so that I can recall previously inputted passwords?


6 Answers 6



Easier way: View > Configure Columns... > Asterisks

This lets you change the setting and set a keyboard shortcut.

Or as it is pre-configured, just hit Ctrl+H!

I had the same question and have found a better solution thanks to answering this question.

The menu item seems to have disappeared somewhere during a version update.

To manually change this setting look in the file KeePass.config.xml and find the following tag:

<CustomName />

Change HideWithAsterisks from true to false.

Only downside is you can't toggle it easily.

  • Exactly what I was looking for! I'm not sure why you lost the ability to just press Ctrl+H to toggle the asterisks on and off in the entry list but I am using version 2.19 now and it works great. Thanks!
    – Samir
    Jun 7, 2012 at 21:03

In the 'Edit Entry' window, click on the little box (show/hide password using asterisks) next to the password box. It will show the password in plain text.

KeePass will not remember this setting as default. If you want KeePass to always remember your setting, you should go to Tools > Options > Advanced and mark the checkbox of

Remember password hiding setting in 'Edit Entry' window

which stands at the 5th line from the bottom.


I used this simple solution after upgrading to 2.18, to unhide passwords

  • Click on View
  • Then Config Columns
  • Then on the Passwords Column
  • Then uncheck the Hide Data Using Asterisks

Hit Ctrl+H. That's easiest way.

(Password hide/unhide states are saved even if the program is closed)


right click the "Password" title and it shows an option to unhide. just found this out. ctrl+h didn't work and i couldn't find another way to unhide passwords.


Click on menu "View" Then choose command "Config Columns" Then clic on the Passwords line Then uncheck the "Hide Data Using Asterisks" which appear suddenly on the back of the dialogue box

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .