I have Windows 7 Ultimate 64 bit. Things were going well until I had to install Outlook 2007 and Visio 2007 on my machine for some client work. After that Microsoft Office 2007 started trying to reconfigure itself every time i was launched. After some uninstalls, registry cleaning, re-installs, and various other experimental changes I was able to correct the "Configure" issue [for all programs except Visio and I'm willing to accept that].

However, during the process I lost the ability to do "File-->New-->Word Document" and "File--> New-->Excel Document", etc..

I tried repairing Office, but that did not add the menu items back in.

After some searching it appears this issue can be fixed by adding registry keys, as described here. Unfortunately I am unable to add those registry keys. The reg files from the link give an error: "Error Accessing Registry".

I opened up RegEdit and try to add the keys manually, I get get the error "Cannot Create Key: Error Writing to the Registry."

I have also tried some programs such as Creative Elements Power Tools and FileTypesMan to address this issue, but neither one was able to solve it. I didn't get any errors from those tools, but it did not add items back into the "new" menu.

For the most part my experiments have been with trying to get excel in the file new menu, but long term I want to get them all back there.

I am running regedit as an administrator. I have re-assigned ownership of the key in question to the administrator group. I have also given the Administrator group. my login account, the system account, and the everyone account full access to "HKEY_CLASSES_ROOT.xlsx" key [and the "HKEY_CLASSES_ROOT" key). That had no affect.

I also tried to use subinacl.exe to give access to those registry keys, but that did not address the issue.

I'm assuming I did something during my initial attempt to solve the problem that somehow blocked off access to that set of keys. I just have no idea what that would be.

I'm at a loss. While googling has provided plenty of possible solutions to my various problems, none of them have worked.

Any ideas?

3 Answers 3


It might be a matter of permissions.

Try to run regedit as Administrator and follow the directions in this article:

Grant Read Write (Full Control) Permissions on Registry Keys (Fix Cannot Import and Access Denied Error in RegEdit)

  • Thanks! I've seen the article in my research. It doesn't fix my issue. I should have specified in my original answer that I have also taken ownership of the registry keys in question. I will clarify in the question text. I am able to edit values without issues; I just can't create new keys.
    – Reboog711
    Sep 6, 2010 at 17:43
  • This is not normal - you might need to check your system using "sfc /scannow". See this article: sevenforums.com/tutorials/…. Ugly question: Are you sure you aren't infected?
    – harrymc
    Sep 6, 2010 at 18:17

Just a shot, There could have been corruption in those registry keys, they may contain a null character, which can cause similar issues. This software checks for null characters, run it as administrator.


Office is the only software that can trash a registry so badly, besides malware, thanks Microsoft.



While trying to fix this I eventually hosed the registry completely; and the computer wouldn't load. In the end I re-installed the OS from scratch and reinstalled all programs. Things have been working better than ever since doing so.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.