I have my old data on backups now these are atleast 2-3 years old and we used to use DVD-R disks then, I burn using Nero and always verify my disks after burning.

Now I have a new LG GH22NS50 Super Multi DVD Writer which doesn't read these disks, I checked these on my older Samsung optidrive dvd writer and they do detect but this DVD drive doesn't burn DVD's anymore and hence I'm stuck. Does this mean that all my old data won't read on new age DVD writers? I now burn to DVD+R disks but wat about my older data? besides this writer supports DVD-R so why won't it read. When I insert the disk it shows up a blank DVD and windows asks me if I want to burn data to it. Can anyone tell me why and how to solve this?

  • Does it give you option to actually record on the disk, just as the disk was really blank? If yes, then I have a workaround available. – AndrejaKo Sep 7 '10 at 12:51
  • yea it does it asks me if I want to use it as a usb drive or burn to dvd – rzlines Sep 7 '10 at 12:56
  • I have Windows 7 – rzlines Sep 7 '10 at 12:56
  • 1
    OK. I think I've had the same problem, but I was unable to solve it (windows 7 helps a lot in confirming the issue). I'll post what allowed me to read the disks. – AndrejaKo Sep 7 '10 at 12:57

Sometimes windows vista and 7 will detect written disks as blank. From what I was able to find out, this mostly happens if the disks were written by Nero Burning Rom, but I've seen it happen on CD-ROMs and DVD-ROMs too. don't know what's causing the issue or how to actually solve it, but there is a way to read disks.

I've been using InfraRecorder for some time. Old versions of InfraRecorder have a windows explorer-like windows where directories may be browsed. If I put affected disk into drive and then navigate to it using InfraRecorder, I can read data using InfraRecorder and I once I opened disk with InfraRecorder, windows can normally open it until it is ejected. Unfortunately, this feature was removed from new versions of InfraRecorder, but old versions are still available on SourceForge. I don't know which version is the last one to include the needed features, but I do know that 0.44.1 has them. It is available as 64bit version too.

I really hope that someone will be able to find a real solution to this problem.

EDIT Looks like someone may have found an answer to this. Check out this link.

  • 1
    Problem similar to this one but on Vista, OP managed to somehow temporarily solve it: social.answers.microsoft.com/Forums/en-US/vistahardware/thread/… – AndrejaKo Sep 7 '10 at 13:34
  • 2
    i have tried that solution and it doesn't work nor does it works for my friends – subanki Sep 7 '10 at 13:58
  • @subanki +1 for testing and coming back with results. I hope we'll be able to ind a solution somewhere. – AndrejaKo Sep 7 '10 at 14:06
  • 1
    @rzlines Does your version of windows seven support XP mode? Maybe it'll help I'm pretty much out of ideas right now. Does your computer have two optical disk drives? I'm thinking about some GNU/Linux live cd. If it is a problem with windows vista/7, then disks should be readable under Linux. If not, then at least we'll know that we need to look for optical disk recovery solutions. – AndrejaKo Sep 7 '10 at 18:48
  • 1
    @rzlines The DVD drive should be detected by XP and be under My Coputer in Devices with Removable Storage. If it isn't, once the XP Mode is started, you can go to Tools menu above the XP windows and go to settings. There should be DVD Drive option and you should have none, Open an ISO image and Access a physical drive options. Select Access a physical drive and from the drop-down menu select your the letter of your DVD drive. For me this option was the default option once I installed XP Mode. I'm thinking that maybe XP Mode may access DVD drive same way InfraRecorder does. – AndrejaKo Sep 7 '10 at 21:02

I solved a similar problem by uninstalling the "NTI" DVD management program from NewTech that came with the drive.


This seems to be a common problem, you could check if another DVD writer is able to read these DVD-R disks. If that DVD writer is able to read then connect that DVD writer in your Computer and try again . If it doesn't work then it could be a OS problem too. Last time after doing a fresh Windows installation My DVD writer was able to read all discs

Windows people says this http://support.microsoft.com/kb/948177

Their Workaround :

To work around this problem, do not record data to the multisession DVD-R disc by using a consumer electronics recorder. Or, do not make a multisession DVD-R disc if the disc might be used in a consumer electronics recorder.

Note: RW discs require the highest laser power for reading and those are typically the first discs to begin having issues.

  • Interesting article, but not what I'm experiencing. In my case, disks were always written by a computer. It also happened on single session disks too. – AndrejaKo Sep 7 '10 at 13:15
  • 1
    @ AndrejaKo , then I am sorry to say that I have no other idea, I am still googling for it if I find anything I Will post it here – subanki Sep 7 '10 at 13:22
  • I never burn multisession disks, and I have tried to new DVD writers of two different companies HP and LG – rzlines Sep 7 '10 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.