I have this issue lately at work. It drives be nuts, and I finally stopped to ask this question.

It's quite often that an application I've been running just randomly fails to repaint itself for a while, usually in the editor screen. I most often see this occurring with Expression Web, Visual Studio 2008/2010 and SQL Server Management studio. These applications are what I work in the most, so I'm not surprised to mostly see it here. But I was curious if anyone else had a solution for this. I've tried:

  1. Reboots. The screen shot below is about 10 minutes after a reboot.
  2. New Video Drivers. This machine is running a Nvidia Quadro NVS 290 video card with the latest drivers.
  3. Closing other applications, this is the only thing running right now.

As far as hardware, this machine has Dual Quad-Core Xeon 2.83ghz Processors, with 10 gigs of memory, running Windows XP SP3 64bit.

Any help would be great.


Per comments from deleted (wrong) answer:

I'm running dual monitors.

Set it to single display, still occurred. Rebooted, and tried it again, and it still occurred. Switched it back to dual screen. My resolution is only 1400x900 on each.

Expression Web Example

  • I've hit this too, but never as bad as you seem to have it. Is the application you're writing memory hungry?
    – ChrisF
    Sep 7, 2010 at 13:53
  • Nope, they're usually fairly small web apps. But this can occur when I open a small solution, without launching it, so the IDE is using very few resources. (Relatively speaking) Sep 7, 2010 at 16:07
  • Happened again after opening management studio. (Already rebooted about an hour ago) i.imgur.com/crzSi.png Sep 7, 2010 at 16:09
  • 2
    I'm removing my answer because it's not correct. I will start a bounty for you, maybe someone else will have an idea. I can't always correct my own issues with this either.
    – JNK
    Sep 15, 2010 at 12:01

2 Answers 2


This is apparently a known bug reported on Microsoft Connect for dual monitors.

For example, it was reported here and here for Visual Studio 2010, with the following workarounds suggested by people (not from Microsoft, as Microsoft is still "working on it"):

  1. Change around the display parameters as described in How to Adjust Visual Studio 2010 Visual Experience Settings, as far as this applies to the products you are using,
  2. Disable all DirectDraw and Direct3D accelerations: Go to Display Properties (Right-Click screen/Properties), Settings Tab, Advanced Button, Troubleshoot Tab, Move the slider to the middle.
  3. Remove all toolbars: Tools->Customize->Toolbars, and uncheck all.
  • +1 Mr Harry! - If the OP doesn't respond in a day or 2 I'll give it to you.
    – JNK
    Sep 16, 2010 at 19:58
  • Gave Harry the bounty, I guess OP is no longer paying attention.
    – JNK
    Sep 19, 2010 at 20:21
  • JNK: Thanks. If it solved your problem, could you indicate which part of my answer worked for you?
    – harrymc
    Sep 19, 2010 at 20:32
  • Disabling directdraw accel improved it for me.
    – JNK
    Sep 19, 2010 at 21:43

It sounds like a problem with the video card. You've ruled out drivers, although I should ask if you know for sure you installed the 64-bit drivers.

The video card may be defective, but it may also just be improperly seated. If you're comfortable mucking around inside a PC, try powering down, then visually inspecting the video card where it slots into the motherboard. Are the metal slot contacts visible at all? Try removing and re-seating the card, making sure that it's fully inserted. I still encounter cards that refuse to seat properly without some adjustment of the flange that holds the card in place. When a card is properly seated, no part of any of the slot contacts should be visible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.