4

I am a Brit working on Unix in a French company - I am more or less used to the French keyboard now, but one problem I still have is typing a tilde (~).

The best I can do is either:

Alt-Gréé

which gives me 2 tildes, or

Alt-Gréspace

which gives me one. Is there a quicker way? I know it's not a big thing but it drives me crazy!

I am on Windows XP (version française!) but spend most of my time using Putty to talk to Red Hat boxen.

Rich

0

You can maybe use Autohotkey to remap it to a different key combo, but I haven't tried AHK with international keyboard layouts.

They key combos you are using are the correct ones on a french KB, unfortunately.

Edit:

FYI, you need to hit a space after the initial key combo because of the use of tildes over letters in French. If you hit a key (like e or a) after the Alt-Gré then it will add that letter with the tilde over it.

3
  • I'm quite happy pressing Alt-Gr, but I'm surprised there's no way to get it with just two keypresses like on an English keyboard. – Rich Sep 8 '10 at 14:15
  • See my edit - it's because of the use of accents in French. – JNK Sep 8 '10 at 14:17
  • 1
    I've just realised that I can press Alt-Gr+é to get the tilde, and then straight away type Shift-: to get the forward slash, and that works fine, so it's the same number of keystrokes as on a English keyboard, just different ones :) – Rich Sep 9 '10 at 8:13
3

For ~ on a French Canadian keyboard, type Alt+ç

1
  • That is correct! Not sure if it's the right place to ask, but do you know how to put it on the n to get ñ using that same layout? (My Google search led me here) I'm on Mac OS for what it's worth. :) – user144939 Apr 15 '20 at 19:03
0
0

You could just put XP in English mode :)

http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/input_kbd_add_language.mspx?mfr=true

6
  • 1
    ...except that won't correct the issue, since he still has a french keyboard. See en.wikipedia.org/wiki/Keyboard_layout – JNK Sep 8 '10 at 14:30
  • practically You are not even trying to help him – subanki Sep 8 '10 at 14:39
  • 1
    This isn't unreasonable: if you're very familiar with the UK keyboard layout, change the keyboard interpretation to UK and try not to look down at the (now wrong) keycaps. – pjc50 Sep 8 '10 at 14:47
  • It seems like a solution that would cause more issues than it fixed, since he only wants to save one keystroke when he types a tilde, not remap his entire keyboard. – JNK Sep 8 '10 at 14:50
  • He states that he is "more or less" used to the French keyboard, and I assume he is familiar with the UK/US layout more. Most people I know aren't very familiar with the language options in XP, so I threw this out there for him if he'd rather use a US layout. – Garrett Sep 8 '10 at 16:31
-1

I've just figured it on mac keyboard AZERTY belgian running emulated linux. Combination of Shift+Option+m followed by space outputs ~

2
  • The question contains a three-key sequence and asks for a quicker way — so you post a four-key answer? – G-Man Says 'Reinstate Monica' Apr 1 '20 at 23:30
  • Yes, you are wrong. Because three key combination is just enough and followed by "n" outputs ñ as in "ninño" 😁 – bol_zeba Apr 6 '20 at 21:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.