Hey guys. I just got this KVM Switch that works really well so far. However, I prefer to use my macbook (unibody, early 2009) in clamshell mode so that it sets the external monitor as the primary monitor.

Without the KVM switch, I would normally just connect the external monitor directly to the macbook, along with my keyboard and mouse, and then close the lid. Once closed and in sleep mode, I would click my mouse button or press a key on my keyboard to 'wake it up' and thus put it into clamshell mode. This would also wake up my external display and use that as the primary display.

I also do this because I would rather have just one monitor running; having the macbook open distracts me (although yes, there may be situations in which having both displays would be beneficial).

Right now, with this, KVM, I can't seem to get this to work. I close the lid, the monitor and the macbook seemingly go into sleep mode as expected. Then when I click the mouse or press the keyboard (both of which are still powered: they are both lit up), nothing happens.

I think maybe when the macbook goes to sleep and brings the monitor in with it, the monitor's new status is signaling to the KVM that this computer is no longer 'active', or something.

By the way, the cable that goes to the macbook is just one: the DVI cable. From it sprout the USB connections (2: mouse & keyboard), and audio connections (mic and line out). Like I said, the peripherals, which would normally bring the macbook back from sleep and into clamshell mode, are still lit up so they are still being powered.

I googled around a bit but the phrase doesn't seem to be prevalent.

My KVM supports some functions (the relevant ones are listed):

  • enable/disable mouse emulation
  • enable mac keyboard emulation
  • perform a usb keyboard and mouse reset (no idea what that means)
  • capture and store monitor's EDID on specific port (tried it, can't tell what it does)

Any help would be greatly appreciated :)

I do know about insomniaX, that works but it still reserves the macbook display as the primary display. I can enable the 'mirror displays' option but then it uses the lowest resolution of the two; the macbook's display, which defeats the purpose of having an external display (1680x1050).

EDIT: Okay, after a lot of screwing around, apparently I got it to work, but I'm not entirely sure how I did it.

I think what I did was capture the monitor's EDID when on the macbook, then closed the lid, then pressed some buttons, but nothing happened for a while so I switched to my windows pc, output the settings. Then I went back just to check on it and it worked! My guess is that it does work but it takes a long time to 'start up'. I will try this again until I nail down the process, for science!

EDIT 2: Yeah, I can't figure it out. I do think, though, that when I plug the connector in when the macbook is already closed, the KVM treats it as a pc instead of a mac. I've gotten it to work about three times now including the first time but I can't figure out what caused it to work, because it has taken a while each time. I close the lid, press my mouse/keyboard, nothing happens for a good while. After a while I get the EDID since I figure maybe I have to do that. Nothing. I turn on mouse emulation, nothing. I switch back to the pc, after a while I check back up on the mac and it's suddenly working. This is pretty frustrating :/


After hours of troubleshooting, I figured it out.

Basically, the MacBook requires that you have the KVM switch's mouse emulation enabled. This, I believe, will allow for the KVM to continue to send the mouse information to the MacBook even when the display is disabled, or something to that effect.

With mouse emulation enabled, I switch to my mac, put it to sleep, click the mouse, switch to windows (I guess to let it 'refresh' or something), switch back to mac and it works as I wanted :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.