The question is - how to fix it?

I have a BCK-08 ( http://www.dealextreme.com/details.dx/sku.8422 ) bluetooth headset that features better quality stereo audio (A2DP). It's built around a IS1621N ( http://www.issc.com.tw/stereo.htm ). It connects to an USB Bluetooth stick (logilink bt0007 with csr chipset, http://www.logilink.eu/showproduct/BT0007.htm?seticlanguage=en ).

Now Windows 7 has significantly improved audio handling. The device is found. When activated, it shows up in mixer as Bluetooth Audio Renderer.

However, while the headset mode always seems to work, I have to "remove" the device from the bluetooth list, and when I "add" it again, it just works.

Now what could interfere? Sleep mode, Skype, Realtek Audio Manager? Bad drivers? Problem with CSR chipset? Problem with IS1621N? BIOS USB settings?

I don't have any other devices so I can't swap. I think chances are litte someone else has this problem, but maybe has more experience in getting misbehaving hardware to work as it should.. :-)

  • no additional drivers installed for either device (not sure what Win7 does, but I think it's all MS default drivers) – none Sep 9 '10 at 13:39
  • Have you tried pairing your headset with other devices (phone, for example) and see how it works in A2DP mode? – Andrejs Cainikovs Sep 9 '10 at 14:02
  • Also, Windows might connect your headset automatically to headset profile, perhaps all you have to do is to disconnect from headset profile, and connect to stereo one. – Andrejs Cainikovs Sep 9 '10 at 14:04
  • Thanks, I've disabled the other services but behaviour does not change. – none Sep 13 '10 at 10:25

Got the same or similar problems. After standby/hibernation I need to disable and enable the service, so you don't need to repair. Also turning the headset on and off works. I also like to use older drivers, but there I experience BSOD's.

Basically you are reloading the driver then. I am assuming you are running the 5.0.14 latest drivers. These drivers are not strictly speaking inbox, although they used to be planned as such, and they were in the release candidate. You probably downloaded them automatically from windows update.

They are courtesy of CSR, but they don't support them. Microsoft does not support them, as they are not inbox. Microsoft claims the headsets manufacturers should support them. The headset manufacturers claim they should be supported by the dongle manufacturers. These typically ship with alternate bluetooth stacks, which support a2dp profiles. Examples of bluetooth stacks are toshiba, bluesoleil and widcomm.


Think I found the solution after constantly surfing the web. Turns out the CSR chipset devices contain an average of 5 bluetooth serial communications, each pertaining to a different function of the headset. When you connect your headset, you'll get 2 Playback (headphone) options, and 1 Recording (mic) options. The first playback option is "Bluetooth Hands-free Audio", and pertains to call-like activities. This is an 8000hz audio device and used more specifically with the answer call keysets. When pairing your device, CSR chipsets have a variety of ways they connect your device. Mine, like most I'm sure, connects into call mode, which activates this hands-free audio. While this is active, the "Bluetooth Audio Renderer" functionality is disabled entirely. This is your 44.1/48khz audio output for media playback.

[tl;dr] Rather than re-pairing, simply open your bluetooth devices and double click the Handsfree Profile. Your headset (if smart) will chime the call disconnect tone (in my case, a voice). Your media playback device should now output to the headset. Since answering a call with the call key will reactivate this, I suggest you disable this entirely by right clicking -> Disconnect.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.