51

I'm using Safari to preview web pages as I develop them on my local server. I've got 'Disable Caches' checked in the Develop menu. And yet Safari is still working from a cached version of a stylesheet that's linked from the HTML file being displayed.

I can sometimes override this by Option-clicking the reload button in the location bar, but I want to refresh the page automatically when I save the CSS file. At the moment I'm doing it using an AppleScript that's bound to the Save action in my text editor. I could see using Keyboard Maestro instead. But I need some consistent way to force Safari to do a full reload from the keyboard.

1
  • Do you have any extensions installed. Had this problem once with Adblock... It messed up one page in particular, thought it was a stylesheet problem too, tried everything... but it was Adblock messing with it.
    – unom
    Jan 8 '14 at 22:08
50

Enable the Develop menu from Safari menu - Preferences - Advanced.

On Safari version 11.1 and above :

CMD+OPTION+R reloads the page ignoring cache.

On Safari version 9 and above :

CMD+SHIFT+R reloads the page ignoring cache.

Emptying caches seems not to reload the stylesheets everytimes…

On Safari below version 9 :

Empty cache and then reload so full "hot key" would be :

CMD+OPTION+E

Then

CMD+R to refresh the page

Of course probably turning opening and closing a New Private Windowfrom the File would also work but…

5
  • that didn't work for me on Safari 8 Sep 11 '15 at 5:49
  • 3
    Safari version 9.1.1 does not reload the page with Cmd-Shift-R. I have "Show Develop in menu bar" enabled.
    – Jason
    Jun 21 '16 at 13:46
  • cmd+shift+R didn't work for me in 9.1.3 either
    – sfletche
    Oct 13 '16 at 17:07
  • 1
    Cmd+Shift+R didn't work in Version 10.0.1 (11602.2.14.0.7).
    – Snowcrash
    Feb 14 '17 at 10:59
  • Checkout @sayan's answer below for a working shortcut
    – Vlad
    May 17 '18 at 14:35
14

The shortcut has now changed to OPTION + CMD + R. (Safari 11.1)

1
  • 1
    Works perfectly!
    – kerrin
    Apr 25 '18 at 4:23
7

There is an option in the menubar Develop->Disable Caches. This is true for Safari 5.1. I'm not sure for the rest.

Screenshot

2
  • 2
    Please read the second sentence of my question again.
    – Gabe
    Jul 28 '11 at 17:06
  • 1
    Oops, I'm sorry :)
    – mist
    Jul 29 '11 at 7:01
2

Turn on Private mode and refresh the page. It won't get it from the cache in private mode.

2

Hard refresh was removed as a keyboard shortcut in Safari 5. The old command for that was +SHIFT+R

CTRL+F5 May work but I can't test here.

6
  • Yes, that's how to refresh the page, but it doesn't bypass the cache.
    – Gabe
    Sep 9 '10 at 16:02
  • 2
    Control-F5 just selects the location bar, like Command-L.
    – Gabe
    Sep 9 '10 at 16:45
  • Then it's been disabled completely. I found a number of threads complaining about it. There is an extension that I have NOT tested here: twitter.com/siracusa/status/15683201068 that may do what you want.
    – JNK
    Sep 9 '10 at 16:47
  • No, that extension just creates a button in the toolbar (which I guess some people prefer to the icon in the location bar). I also found a lot of threads complaining about it—i was wondering if someone on here had any special knowledge.
    – Gabe
    Sep 9 '10 at 19:37
  • Sorry! :( <15chars>
    – JNK
    Sep 9 '10 at 19:47
1

Workaround: in the develop menu, select "start debugging javascript" and it must reload the code properly. You can then stop debugging... I know it's not a clean solution and I'm not sure if it works always or in all versions, but it's working for me now.

1

I stumble upon this question and apparently the current answers do not work.

Issue is currently CMD+ALT+R opens the Responsive design.

However if the inspector is open via CMD+ALT+I, then the same shortcut does a clean refresh.

Current Safari Version: 12.1.2

0

CMD+L focus on the address bar SHIFT+ALT+ENTER full reload for the current address

It seems to work on Safari 9

2
  • And how does one click without a mouse?
    – qasdfdsaq
    Oct 23 '15 at 12:51
  • 1
    @qasdfdsaq My bad, edited the question.
    – rraallvv
    Oct 23 '15 at 13:00
-3

Go to Safari's preferences and tick "Show develop menu". In the develop menu, click disable Caches.

1
  • 1
    Please read the second sentence of my question.
    – Gabe
    Feb 21 '13 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.