I have no idea why my CD-ROM/DVD drive doesn't work anymore. When I insert a disk it makes noises and opens again. If it matters, I just reformatted the computer from Ubuntu 10.04 to Ubuntu 9.10. Most likely software settings problem or something.

What could be wrong and how can I fix it?

Edit: Though when I try to run my Ubuntu Installer CD from boot it works fine.

  • Ubuntu might be ejecting the disk it can't recognize. What's on the disk? – Dummy00001 Sep 16 '10 at 12:28
  • the first disk if full of .avi files and the second is full of .xls files – Dian Sep 17 '10 at 1:05

Try and boot from a live CD image (eg. your Ubuntu install disc). If that works then it eliminates your current Ubuntu installation and probably points to hardware failure or a changed BIOS setting.

  • I tried running the Ubuntu install disc from boot, it worked fine. CDs that can run from boot are fine. When I try to run my movie cds (not from boot), it does that eject thing. – Dian Sep 13 '10 at 8:29
  • OK, so that means the hardware is ok and it's a software issue. Have you tried a data CD? Does it have the same issue as a movie CD/DVD? – Mike Fitzpatrick Sep 13 '10 at 10:25
  • I tried a data CD, yeah it has the same issue as the CD/DVDs. – Dian Sep 14 '10 at 7:04

Does it do that even if your O/S isn't running? For instance, if you go into your BIOS setup (thereby avoiding booting Ubuntu) and then insert a disc, does it make noise and eject? If so, then it could be a mechanical problem. How old is the hardware? Dust has a way of building up in every possible crack in systems that are left on all the time, including inside optical drives. If you can open the drive, blast some compressed air in there. If dust blows out, you might want to consider removing the drive, opening it and cleaning it.

  • No it's doesn't eject if ubuntu isn't running. – Dian Sep 13 '10 at 8:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.