On Unix I'd just use vi, but I don't know what the command is on Windows. I am actually trying to edit files over SSH with Windows Server 2008.


edit filename

I won't vouch for its functionality and outdated GUI but it is installed by default, even on Windows 7.

Edit: Except 64 bit versions of Windows.

  • 13
    On all versions of Windows? There is no "edit" on Windows 7 apparently. – Snark Sep 10 '10 at 3:53
  • 12
    Odd... evidently it's installed by default on Windows 7 32-bit, but not on Windows 7 64-bit. That's sad. – nhinkle Sep 10 '10 at 4:12
  • 6
    @nhinkle: I seem to recall reading something about 16-bit apps being unavailable under 64-bit windows installs. – intuited Sep 10 '10 at 4:34
  • 4
    Confirmed NOT working in Win 10... I really cant believe Windows is lacking such basic tools and nobody even seems to care – Rafael T Aug 30 '17 at 11:59
  • 2
    This is just wrong answer when talking about "Windows" generally. Today, Windows is also Win7-64bit, Win8-64bit, Win8.1-64bit, Win10. "edit" cannot be the correct answer to the question from today's point of view. – Mehrdad Mirreza Nov 9 '17 at 10:40

The simplest solution on all versions of Windows is:

C:\> notepad somefile.txt

And, no extra software required.

  • 27
    Nice, but not over SSH – Casebash Sep 10 '10 at 4:10
  • 4
    Ah. Right. Windows doesn't have a command-line editor built in. You'll probably need to install the Gnu version of the editor you want to use. Since you've already installed the ssh server, that should be no problem for you. – BillP3rd Sep 10 '10 at 4:27
  • 8
    Like OP said... "I am actually trying to edit files over ssh..." – daviewales Apr 13 '14 at 3:16
  • 7
    useless answer, both for ssh users and for those who wants to edit files IN cmd window, not outside it – vladkras Feb 14 '16 at 7:10
  • 3
    This will not work in a Docker container based on 'windowsservercore' – Peter Mortensen Aug 28 '18 at 9:17

From a Windows command prompt enter copy con followed by the target file name. (copy con c:\file.txt).

Then enter the text you want to put in the file.

End and save the file by pressing CTRL-Z then Enter or F6 then Enter.

If you want to change text in an existing file simply display the text by using the command type followed by the file name and then just copy and paste the text in to the copy con command.

  • 7
    Hard core. Try not to make any typos, or you'll have to start over again. Well, backspace does work if you catch the mistake before you press Enter. – Kevin Panko Dec 3 '13 at 18:57
  • Doesn't seem to work with psexec. Tried to edit my hosts file with copy con hosts but ^Z doesn't save and ^C doesn't cancel! Had to close the cmd window to get out. The file was unchanged. – Iain Samuel McLean Elder May 27 '14 at 11:17
  • Note: F6 can be used instead of [Ctrl]-[Z] – MonoThreaded Sep 13 '14 at 9:58
  • In a Docker container based on 'windowsservercore' (CMD), Ctrl + C worked for the terminating key sequence. – Peter Mortensen Aug 28 '18 at 9:30

If you're used to vi and don't want to settle for the built-in editor you can get Vim for Windows. It'll run from a command shell. Or try WinVi.

  • this should me marked as answer because edit has been removed from win 10 – Luke Jun 14 '18 at 18:36
  • 1
    It is much better than that: It also works inside a Windows Docker container (it is easiest to get the "Win32 console executable", e.g. vim81w32.zip - unzip and copy vim.exe to wherever it is accessible in the Docker container). – Peter Mortensen Sep 15 '18 at 23:38

Believe it or not, EDLIN.EXE is still around <shudder> at least on this Vista system.

Excuse me while I sob softly to myself...

  • 6
    It was finally deleted in Windows 7 (at least the 64-bit versions). – paradroid Sep 10 '10 at 7:11
  • 1
    @jason404: It's still included in 32-bit Windows 7. – Dennis Williamson Sep 10 '10 at 15:08
  • 2
    edlin is a 16-bit program, therefore it is not available in 64-bit versions of Windows. However, I won't be surprised if someone here claims it's still present in the 32-bit version of Windows 10. – TSJNachos117 May 12 '15 at 7:54
  • 1
    @TSJNachos117 It is indeed in x86 Windows 10. – Brian Duddy Oct 12 '16 at 1:19
  • Not surprised at all. – TSJNachos117 Jan 30 '17 at 21:44

I don't know about SSH, or anything (else?) server-related, so forgive me if this "solution" is useless. If you want to edit files in the command prompt, you can get the Windows version of Nano.

As a side note, those little ^ signs at the bottom of the window are supposed to represent the Ctrl button. For instance, ^X Exit means that you can exit the program using Ctrl-X.

Also, Nano will sometimes add extra newlines when saving files. This seems to be some kind of bug with Nano's word wrapping.

I've also seen ports of vi for Windows, although I've used one that just seem to make command prompt window as small as it can be, leaving only a title bar (which means the rest of the window may as well be invisible, since you can't see what you're doing). However, the Windows version of Vim seems to work quite nicely.

protected by slhck May 24 '15 at 16:40

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.