I ordered a replacement screen from Dell after an unfortunate accident and once installed I can't get it to work. I only get a blank screen with cursor on corner. If I use an external monitor then windows boots up and all is fine. I don't known what to do. Dell won't help me at all, saying the screen is fine. i tried some BIOS changes but nothing seem to work. I feel this must be some little stupid thing I am missing. Any help?

Note: Asking by proxy. Meaning LtPinback is helping out a non-english speaker user from Spain so answers and acknowledgments may take some time.

  • Which Windows and is the screen resolution of your new monitor same as the old one – subanki Sep 11 '10 at 10:04
  • Does the laptop screen work during boot? – Nifle Sep 11 '10 at 11:40
  • @subanki Windows 7 and the screen is a direct replacement from Dell so I guess yes same resolution. – LtPinback Sep 11 '10 at 12:43
  • @Nifle No, that is why I think it is a BIOS issue. – LtPinback Sep 11 '10 at 12:44
  • I don't get it - do you see any video output on the screen? What do you see in the Nvidia Control Panel when you boot up using an external monitor? It should reveal the display parameters (it's possible they replaced the screen with one of a different resolution...). – Breakthrough Dec 1 '12 at 15:46

Try these

  1. Unplug the AC adapter and remove the main battery, hold the power button down for 15 seconds, plug in the AC (leave the battery out), see if it works now.

  2. If #1 fails to give results, remove AC power and main battery, locate the cmos battery and remove it for 15 minutes, reinsert the cmos battery and plug in AC only, try to boot.

Removing the cmos battery will be a project, it requires you to access the motherboard inside the Laptop.


This document should be available in different languages under "Service Manual" http://support.dell.com/support/edocs/systems/vos1520/



  • Option 1 did not work. Option 2 is not possible as the cmos battery is soldered onto the mb. – LtPinback Sep 13 '10 at 15:00
  • The manual must be wrong then, it shows it as removable. – Moab Sep 13 '10 at 15:58
  • yep I will double check with the person affected. Maybe he didn't locate the cmos battery properly or mistook the instructions. – LtPinback Sep 13 '10 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.