22

I would like to set Y and P to copy and paste directly to the system clipboard instead of vim buffer.

I don't want any additional commands. Just the normal ones, but they should copy to and paste from the system clipboard and bypass the vim buffer.

How can I achieve this?

I'm running vim on Ubuntu 10.10.

0

6 Answers 6

9

You can have Vim use the clipboard instead of the default register for yanking, putting, etc., by adding this command to your ~/.vimrc:

set clipboard+=unnamed

See

:help clipboard
:help 'clipboard'
2
23

You first need to see if vim is compiled with clipboard support, run vim --version | grep clip and see if there is a + or - in front of clipboard and xterm-clipboard.

If it has clipboard support, copying from and pasting into the * or + registers should use the system/X11 clipboards, so "*yy would copy a line and "*p would paste it.

In Ubuntu 10.10 you can install vim-gnome to have clipboard support compiled in.

1
  • 3
    I tried both this and the method above but I can't get it to copy to system clipboard. It works fine inside Vim though.
    – Owais Lone
    Nov 12, 2010 at 9:56
9

have a try :

"+y   and    "+p

this works for me, on Ubuntu.

1
  • 1
    This one works for me, not the * version. Why are people reporting different things?
    – trusktr
    Apr 6, 2013 at 7:37
6

The default VIM in Ubuntu is vim-tiny, which is not compiled for system clipboard support. You need to install the full VIM and the Gnome GUI to get clipboard support:

sudo at-get install vim-full vim-gnome

After you install those two packages you can then use the commands that Akira and wliao mentioned.

0

yank to the clipboard register:

 "*y

paste from the clipboard register:

 "*p

for more information:

 :help clipboard
6
  • It doesn't work. Works fine in Vim itself but does not seem to affect the system clipboard.
    – Owais Lone
    Nov 10, 2010 at 8:11
  • Oh, it's not working because my version is 7.2 and this seems to be supported in 7.3 only.
    – Owais Lone
    Nov 10, 2010 at 8:22
  • Then why not upgrade?
    – harrymc
    Nov 29, 2010 at 20:33
  • It works for me exactly as described, except using +. "+yy.... Why?
    – trusktr
    Apr 6, 2013 at 7:38
  • @trusktr: look at the answer of steabert.
    – akira
    Apr 6, 2013 at 15:49
0

On my Ubuntu 18.04 (GNOME Shell) this enabled clipboard:

sudo apt-get install vim-gnome

vim --version|grep clipboard
+clipboard         +jumplist          +persistent_undo   +virtualedit
-ebcdic            +mouseshape        +statusline        +xterm_clipboard

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .