17

When I try to connect my pidgin to my gtalk account it doesn't work anymore. What should I do? The error is

Not Authorized

I used

  1. Protocol XMPP
  2. Username without @gmail.com
  3. Domain gmail.com (default)
  4. Checked Require SSL/TLS (default)
  5. Connect port 5222 (default)
  6. File transfer proxies proxy.eu.jabber.org (default)

All other options are unchecked or empty

The instructions at Google Talk Support or Google Talk Support Forums didn't work for me

  • Some general troubleshooting questions: 1. What OS? Windows or Linux? 2. Is there anything we should know about your network or Internet acess? 3. Does Pidgin work with other IM protocols, or even Facebook's XMPP Chat? 4. Does it work in any other client? – digitxp Sep 12 '10 at 0:09
  • @digitxp Windows 7, gtalk works with official client, pidgin works as a msn messenger client. – Jader Dias Sep 12 '10 at 0:12
  • Could you clarify whether you set the "Connect Server" option? It isn't in your list of settings but is mentioned on the forum thread you said didn't work. – moberley Sep 12 '10 at 3:39
  • @moberley I tried both ways. Today it began unexpectedly to work. – Jader Dias Sep 12 '10 at 16:13
  • I think it began to work after I installed the facebook plugin – Jader Dias Sep 13 '10 at 11:07
4

Make sure the connect server is talk.google.com

Check the password (Duh?)

Try unchecking the security, just to see it it will connect without it.

update pidgin?

|improve this answer|||||
  • I think it began to work after I installed the facebook plugin – Jader Dias Sep 13 '10 at 11:06
31

What solved this error for me was logging into http://accounts.google.com/ Then under the "Signing In" section I chose "Access for Less Secure Apps". It was disabled, and once I enabled that option, Pidgin was instantly able to connect.

|improve this answer|||||
  • Thanks for this, I missed that option in the account page, and most responses for "Not Authorized" are only for two-step verification problems. – Alberto Martinez Apr 15 '15 at 14:21
  • My problem too. This was the first place that I found that even suggested looking at that setting. Many thanks! – jschabs Jun 16 '15 at 13:07
  • This is the right solution. Work as well on Ubuntu 15.10. It could be the accepted answer. Thanks! – Fernando Kosh Feb 3 '16 at 22:28
  • 2
    This solves the issue, +1 for that; but I wonder will it make my gmail vulnerable? :o – Ali_Waris Dec 27 '16 at 18:05
  • @Ali_Waris No, from what I could find searching, and google's own help, google's "less secure apps" really only means "non-google apps" like Mozilla Thunderbird, and the security is at least as good. – Xen2050 Dec 26 '18 at 4:55
7

Look at this post This worked for me:

Go to your google accounts by logging in to http://accounts.google.com/ In the ‘Security’ menu (left side of the window), go to the 2-step verification section Under this section.,

click the ‘Manage your application-specific passwords’ link. Sign-in again (if prompted)

Set any name relevant to the application. For example, pidgin-messenger and hit the ‘Generate Password’ button. Copy the password generated (along with the spaces, it doesn’t matter) and hit the ‘done’ button.

Now, hit the ‘Modify account’ button on the Pidgin window, paste the copied password in the ‘password’ text box and click the ‘save’ button. You will again be presented the ‘Add accounts’ window. In this window try again to tick the ‘Enabled’ check box

|improve this answer|||||
4

I work for a security company, so things are locked down pretty tight inside the firewall. Iwent to the advanced section for the XMPP client and selected use "old-style SSL" for connection security, 443 for connection port, and talk.google.com for connection server. Now it's working fine.

|improve this answer|||||
1

Same problem. I've discovered that my gtalk account was blocked by google (maybe) and that's why pidgin wasn't able to connect. So I downloaded gtalk and login for once. After logoff pidgin established connection to gtalk.

|improve this answer|||||
1

Be careful if your passwords contains the dollar sign($), it isn't parsed correctly on Pidgin and leads to "Not Authorized" errors

|improve this answer|||||
1

Just spent a few hours struggling to get Pidgin work with 2-step verification. It looks like Google Accounts website structure has been changed, making all the instructions and links on the web outdated. It's especially misleading that Manage Apps and App Passwords are two different sections.

Updated Guide for Adding App Specific Passwords to Google Account

Here's how to navigate to App Passwords section:

Google Accounts > Signing in to Google > App Passwords

Or use the direct link below:

https://security.google.com/settings/security/apppasswords
|improve this answer|||||
0

i have multifactor authentication enabled. i had to create an app password for pidgin.

  1. went to myaccount.google.com
  2. clicked Sign in & Security
  3. clicked "app passwords" (in Password & sign-in method box)
  4. Select app -> Other. Give it a descriptive name.. like pidgin.
  5. Enter this key in the password field in pidgin.

hope this helps some of you.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.