I downloaded a tar.gz for the Player Project from Sourceforge. I ran the make install command to install it, and got no errors. But I don't know how to actually run the program. There are multiple .exe files relating to it in the /usr/local/bin folder. However, nothing happens when I attempt to run them with Wine. I tried running the player.exe file from the terminal and I get this error -

player: error while loading shared libraries: libplayerdrivers.so.3.0: cannot open shared object file: No such file or directory

I get that it’s obviously saying I am missing a file, but I don't know what to do about it. I tried reinstalling it and still get the error. Is this something wrong with the tar.gz I downloaded or am I doing something wrong to run it?

  • 1
    .exe files in a Linux program? – mathepic Sep 11 '10 at 23:52
  • This is more applicable to superuser.com, or ubuntu.stackexchange.com (or unix.stackexchange.com). – David says reinstate Monica Sep 11 '10 at 23:53
  • I was reading at and stopped at ".exe files in /usr.." - then I started being "WTF?!?" – halfdan Sep 11 '10 at 23:54
  • 1
    @mathepic and halfdan: From his statement it looks like he is running Wine, which is a type of Windows emulation. Wine allows you to run certain exe files. – linuxuser27 Sep 11 '10 at 23:54
  • @linuxuser27 Except why would you use a make install for a Windows program? – mathepic Sep 12 '10 at 0:46

If you ./configure/make/make install you should just be able to run them from the command line. If they end with .exe and they are Linux native(seems like it), then they are mono executables.

The thing about the .so implies you are missing the needed shared library.

| improve this answer | |

On Debian (should be the same on Ubuntu or other Debian-based distributions):

$ apt-file search libplayerdrivers
libplayerdrivers3.0: /usr/lib/libplayerdrivers.so.3.0  
libplayerdrivers3.0: /usr/lib/libplayerdrivers.so.3.0.1  
libplayerdrivers3.0: /usr/share/doc/libplayerdrivers3.0/changelog.Debian.gz  
libplayerdrivers3.0: /usr/share/doc/libplayerdrivers3.0/changelog.gz  
libplayerdrivers3.0: /usr/share/doc/libplayerdrivers3.0/copyright  
libplayerdrivers3.0-dev: /usr/include/player-3.0/libplayerdrivers/driverregistry.h  
libplayerdrivers3.0-dev: /usr/lib/libplayerdrivers.so  
libplayerdrivers3.0-dev: /usr/share/doc/libplayerdrivers3.0-dev/changelog.Debian.gz  
libplayerdrivers3.0-dev: /usr/share/doc/libplayerdrivers3.0-dev/changelog.gz  
libplayerdrivers3.0-dev: /usr/share/doc/libplayerdrivers3.0-dev/copyright  
robot-player-doc: /usr/share/doc/player/html/group__libplayerdrivers.html`

...so maybe you just need to install libplayerdrivers3.0. When you ./configure, the script should really warn you about missing libraries, but that script might be defect.

I'm not sure of what program installs .exe files in your directory structure and requires you to use wine to run them, but closing my eyes to that, the above written is the first thing I'd try.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy